x-sync flash only works on bulb

Discussion in 'Camera Building, Repairs & Modification' started by amuderick, Nov 27, 2008.

  1. amuderick

    amuderick Member

    Jan 13, 2007
    Large Format
    My Sputnik has developed a problem. The x-sync has started acting odd. Occasionally it will actually fire the flash when the shutter trips. Most often, it doesn't. I've tested it on a flash (Rollei E36RE) and flashbulbs. Same result.

    If I set the shutter to bulb, the flash fires every time. But, on 1/15, 1/30, 1/60, 1/125th, etc, it doesn't trip. The odd thing is that on the flashgun, I can see the ready light flicker when the shutter fires. If I open up the lens to watch the action, I can see the arm make contact with the x-sync post, spark, and then pull away. Since it is sparking (and the flash ready light flickers), I know it is making contact.

    Why doesn't it fire? How can I fix it?

    I've tried contact cleaner on all surfaces as well as a bit of abrasion to improve the contact surfaces. No luck so far.
  2. Kino

    Kino Member

    Jan 20, 2006
    Multi Format
    Could it be that the resistance of the circuit has grown stronger with age and corrosion and that the B setting allows enough current to pass to trip the flash, while the momentary contact simply will not allow enough "juice" to flow?

    Not being familiar with the contacting surfaces, I'd ask if there might be a way to put a light dab of silver soldier on the tips of the connections? If not, maybe some conducting enhancement fluid of some sort?

    Also, I'd try to trace the entire path of the flash circuit and look for corrosion.

    Just a guess...
  3. John Koehrer

    John Koehrer Subscriber

    Apr 3, 2004
    Multi Format
    Can you increase the pressure on the contacts? It may be that the contact isn't solid enough to firmly close the switch during the timed speeds. (switch bounce)