Yashica Electro35 Lens issue

Discussion in 'Rangefinder Forum' started by JohnRichard, Jul 12, 2013.

  1. JohnRichard

    JohnRichard Member

    Messages:
    263
    Joined:
    Apr 27, 2008
    Location:
    Lexington, K
    Shooter:
    4x5 Format
    I purchased my Electro 35 GSN at a flea market for a song. I love it.
    However, after several trips in the carry-all bag it has developed an issue where the "scene select" ring is loose. Through this looseness I believe there is a light leak to one of the inner elements
    of the lens groups. Is there a lens hood or other something that I could use to fix my weak lens issue? I'll never find another one for the price I paid.
    I could try to tape the lens back together. It's really just the plastic housing on the outside of the lens.

    Thoughts?
     
  2. Mustafa Umut Sarac

    Mustafa Umut Sarac Member

    Messages:
    4,576
    Joined:
    Oct 29, 2006
    Location:
    İstanbul
    Shooter:
    35mm RF
    I dont know the camera but may be flexible textile bant can be an option. If you are not willing to contact with annoying nylon tape to your fingers , you can use glued leather or sail textile to make a more pleasing contact. just a thought.

    May be there is option to disassemble the mechanism and play with loose screw but for me , I cant do it.

    Others would explain this option , may be there is repair manual at google , have a look at it.
     
  3. Mustafa Umut Sarac

    Mustafa Umut Sarac Member

    Messages:
    4,576
    Joined:
    Oct 29, 2006
    Location:
    İstanbul
    Shooter:
    35mm RF
  4. JohnRichard

    JohnRichard Member

    Messages:
    263
    Joined:
    Apr 27, 2008
    Location:
    Lexington, K
    Shooter:
    4x5 Format
    AWESOME! Thanks for that link. I am ready to destr.... repair my camera!
     
  5. JohnRichard

    JohnRichard Member

    Messages:
    263
    Joined:
    Apr 27, 2008
    Location:
    Lexington, K
    Shooter:
    4x5 Format
    Yaschica9_zpsb7ea640c.jpg
    Yaschica10_zps48c20442.jpg
    Yaschica11_zps72fcdc27.jpg

    Here you find the rings under the front element.
    I think I am missing three screws, is that correct?
    Where can I find them?