PDA

View Full Version : 1936 bessa won't open



SteveinAlaska
09-28-2008, 03:32 PM
I'll admit to using this camera a lot in the last three months. I shot about 10 rolls of film thru it.
I went to open it the other day and it only opens to about 45 degrees and then stops. I don't want to force it open. The day previous I had a problem with the shutter trigger not working so upon inspection it seems that the trigger mechanism has worked loose from the shutter release. So to shoot the camera,I would just push the shutter release. I do the same thing with my Zeiss Ikonta 521/16.
I am going to use a strong light to look in and around the camera to see if something is binding or has worked loose for a start. Just wondering if anyone has experienced the same problem?
Thanks for any help.

cdholden
09-28-2008, 03:40 PM
It may just be that it needs a good cleaning. I had a Bessa I (newer model) that did this. It didn't get jammed. It just wouldn't open on its own. A little help to open it up all the way was all that was needed. When I sent it off to Jurgen for a new bellows and CLA, it came back in much better condition and was no longer sticking when trying to open. I've got a couple of old Pentacon Erconas (Russian made Ikontas). One of them does it too.

SteveinAlaska
10-06-2008, 02:41 AM
Finally got around to looking at it. The filter ring came open somehow and it's causing everything to be bound up. A little patience along with a pot of coffee should free it up!

jolefler
10-06-2008, 11:18 AM
Yikes, Steve!! Coffee is highly corrosive, try gear lube instead!! :>)

Whiteymorange
10-06-2008, 11:19 AM
Yeah, but gear lube tastes like ....

seawolf66
10-06-2008, 11:37 AM
Hummmmm: [A little patience along with a pot of coffee should free it up!] I hope the coffee is for you and the patience for the camera: