Switch to English Language Passer en langue française Omschakelen naar Nederlandse Taal Wechseln Sie zu deutschen Sprache Passa alla lingua italiana
Members: 69,727   Posts: 1,515,176   Online: 963
      
Results 1 to 1 of 1
  1. #1

    Join Date
    May 2010
    Location
    arkansas
    Shooter
    35mm
    Posts
    48

    Minolta Hi-Matic aperture/shutter repair

    I bought a Minolta Hi-Matic at a thrift store for 3 dollars. Though I bought it to go with my massive collection of cameras I have on display in my home, I would like to try to fix it. I thought the aperture was not working, but found out that you have to cock the shutter to adjust the aperture settings. After cocking the shutter, the aperture ring would move, but the blades would not, so I decided to tear in to the lens and see what I could do to fix it. Probably not the best idea being I have only disassembled a lens once, but it was completely broken with no possibility of fixing it (lens was cracked). I just wanted the aperture ring to use as a vignette in my darkroom, which works fantastic. As I was taking the lens apart, a small wire fell out. Where the wire came out is marked with a "c" on the image I have attached. I easily freed the aperture blades. The mechanism that moves the blades is marked with a "b" on the image. My problem is with what I am guessing is the shutter (marked with an "x"). There is a second set of blades in front of the aperture. It will not close completely, thus constantly letting light in to the film plane. Cocking the shutter will close the blades some, but not all the way. When the shutter button is pushed, the blades open almost all the way and will not close back down. Inside the guts of the lens, there is a leaver I can move to the left, and the blades will close completely, but as soon as I let it go, it pops back in place. I have marked the leaver with an "a" on the image. Sure, I may have bitten off more than I can chew, but it is kinda fun to see the inner-workings of my camera. Any info on how to fix this problem would be greatly appreciated.
    Attached Thumbnails Attached Thumbnails camera2.jpg  
    Last edited by rberry65; 08-14-2012 at 03:45 PM. Click to view previous post history.



 

APUG PARTNERS EQUALLY FUNDING OUR COMMUNITY:



Contact Us  |  Support Us!  |  Advertise  |  Site Terms  |  Archive  —   Search  |  Mobile Device Access  |  RSS  |  Facebook  |  Linkedin