Switch to English Language Passer en langue française Omschakelen naar Nederlandse Taal Wechseln Sie zu deutschen Sprache Passa alla lingua italiana
Members: 71,829   Posts: 1,582,203   Online: 981
      
Results 1 to 4 of 4
  1. #1

    Join Date
    Jun 2013
    Location
    Stockton, CA - USA - EARTH
    Shooter
    35mm
    Posts
    88

    Need help with Konica c35 shutter

    I have a Konica c35 Automatic that the shutter isn't firing on. I've checked the battery and the wires all are good and no sign of corrosion anywhere. I also cant seem to figure out which arm is supposed to move and which doesn't. Anyone have any links or repair documents to help me out? Meter works well and is only about 1/3 stop off with a 1.4V zinc cell.


    -Xander
    Last edited by Fast14riot; 12-11-2014 at 05:12 PM. Click to view previous post history.

  2. #2

  3. #3
    David Lyga's Avatar
    Join Date
    Nov 2007
    Location
    Philadelphia, PA USA
    Shooter
    35mm
    Posts
    1,339
    I would remove the front element set and, with a tiny screwdriver, gently touch the shutter blades as you press the shutter button. It could be that there is a tiny bit of oil preventing those delicate blades from initiating their travel. - David Lyga

  4. #4

    Join Date
    Jun 2013
    Location
    Stockton, CA - USA - EARTH
    Shooter
    35mm
    Posts
    88
    Jeff, thanks, I've found all those as well.

    David, I've cleaned these with ronsonol and it worked a couple of times after sitting for a bit.

    I'm thinking it has something to do with the self timer. I guess I will have to break down and buy the factory service manual for these. I do enjoy these tidy little cameras, great lens and I'm sure I could make my money back by fixing some of these for people.


    -Xander



 

APUG PARTNERS EQUALLY FUNDING OUR COMMUNITY:



Contact Us  |  Support Us!  |  Advertise  |  Site Terms  |  Archive  —   Search  |  Mobile Device Access  |  RSS  |  Facebook  |  Linkedin