Switch to English Language Passer en langue française Omschakelen naar Nederlandse Taal Wechseln Sie zu deutschen Sprache Passa alla lingua italiana
Members: 70,480   Posts: 1,542,693   Online: 840
      
Results 1 to 5 of 5
  1. #1

    Join Date
    Nov 2009
    Shooter
    Medium Format
    Posts
    5

    Rolleicord V - film advance does not work

    I just got a Rolleicord V from Swedish Ebay. It was in a pretty bad condition and smelled horrible (note to self: never buy a smoker's camera) but it functions alright. There was a lot of dirt and dust, but I got it pretty clean. The shutter only works on times below 1/30, which is what I had expected.

    The only thing that does not work is the film advancement. I can advance from "0" to "1", but when I hit the first frame (i.e 1) it just stops. I figure this is the double exposure prevention kicking in, but even though I fire the shutter I can't advance the film.

    Am I just doing something wrong or is it broken? I'm thinking that it won't be too difficult to remove the exposure lock completely, but I have no idea how to pick this camera apart. I guess I'll have to strip the leatherette, which I'd rather avoid.

  2. #2
    wclark5179's Avatar
    Join Date
    Dec 2002
    Shooter
    Medium Format
    Posts
    505
    My recommendation is to get a CLA from a reputable tech.
    Bill Clark

  3. #3

    Join Date
    Feb 2009
    Shooter
    Large Format
    Posts
    662
    That’s not surprising. Rollei altered the design every few years. The advance lock on mine is a roughly 15mm diameter spring-loaded black button in the center of the winding knob. It’s finished exactly like the winding knob and is often overlooked by a new owner. The original owner’s manual is almost never sold with the camera. That was the case with mine. I acquired it in 1986 for $50. The film counter mechanism jammed and wouldn’t turn. The Rolleicord film advance is driven by a toothed wheel that rides on the edge of the film. Since it wouldn’t turn, advancing the film wrinkled and tore the edge of the film making the camera unusable.

    I had it repaired at Essex Camera Repair of Carlstadt, New Jersey for $100. It is a shop owned and staffed by Chinese folks. They did a good job. The camera has worked perfectly ever since. Good luck in resolving your problem.

  4. #4

    Join Date
    Nov 2009
    Shooter
    Medium Format
    Posts
    5
    It should be mentioned that I payed over 100€, which was extremely stupid of me. I could probably have got a fully working one for 60€ if I'd had more patience. I won't get a CLA, since it probably would be cheaper to buy a Rolleiflex in good condition (cameras tend to be a bit cheaper in Sweden, but servicing is more expensive than in the US).

  5. #5
    Mats_A's Avatar
    Join Date
    Jan 2010
    Location
    Finland
    Shooter
    Multi Format
    Posts
    571
    Images
    10
    I just had my Rolleicord IV serviced for film advance problem. Cost 80€.

    r

    Mats
    Digital is for communication, film is for documentation.


    http://www.flickr.com/photos/studiopirilo



 

APUG PARTNERS EQUALLY FUNDING OUR COMMUNITY:



Contact Us  |  Support Us!  |  Advertise  |  Site Terms  |  Archive  —   Search  |  Mobile Device Access  |  RSS  |  Facebook  |  Linkedin