Switch to English Language Passer en langue française Omschakelen naar Nederlandse Taal Wechseln Sie zu deutschen Sprache Passa alla lingua italiana
Members: 70,301   Posts: 1,536,171   Online: 719
      
Results 1 to 2 of 2
  1. #1

    Join Date
    Feb 2011
    Shooter
    35mm
    Posts
    2

    Problems unloading the film on Kiev-19

    hello,

    so, i've got this problem: i can't open the back part of the camera (where you load the film)...

    So, the context of this problem is: i bought the Kiev-19 from eBay, and when i received it, i started "taking" pictures right away, because i thought there was a film already installed in the camera... i thought this because everything seemed to point to that fact (espeacially because the picture counter kept going, eveytime i "took" a photo)
    So, when the counter gets to the 36th photo, and i thought that the film had ended, i tried to unload the film... i clicked in the tape transport mechanism release button, so that the back would open... but it didn't! i took some more photos and the counter was still in the 36th photo. i realized "oh well, there's no film inside!"

    that was already disturbing enough, but then i tried "to move on" and focus on opening the back, putting a new film and forget about the 36 pictures i had already "taken"... but, the thing is that now i can't open the back... i keep clicking on the button, i keep pushing the back, and i can't get it open...

    can someone tell me how to do so?
    i suspect something got locked inside the camera, due to the fact of me being "taking" pictures without a film inside...

  2. #2
    Anscojohn's Avatar
    Join Date
    Dec 2006
    Shooter
    Medium Format
    Posts
    2,727
    Images
    13
    The frame counter advances whether or not there is film in the camera. The back opens by pulling up on the rewind knob on the left side of the camera.
    John, Mount Vernon, Virginia USA



 

APUG PARTNERS EQUALLY FUNDING OUR COMMUNITY:



Contact Us  |  Support Us!  |  Advertise  |  Site Terms  |  Archive  —   Search  |  Mobile Device Access  |  RSS  |  Facebook  |  Linkedin