Switch to English Language Passer en langue française Omschakelen naar Nederlandse Taal Wechseln Sie zu deutschen Sprache Passa alla lingua italiana
Members: 75,783   Posts: 1,671,312   Online: 1093
      
Results 1 to 4 of 4
  1. #1

    Join Date
    Jan 2007
    Shooter
    Medium Format
    Posts
    338

    Pentax 67-ii film winder stuck intermittently

    I got a Pentax 67-ii that has developed a symptom that the film winder lever would get stuck intermittently. It usually can recover by itself after repeated attempt to wind without forcing it. It happens about once or twice for every roll of film I shot. It is driving me nuts. Because it is intermittent I am reluctant to send it out for repair. I have hoped that it would cure by itself over time. But it hasn't for about 5 years now. Does anyone have any experience with something like this? Is it likely a small repair?

  2. #2

    Join Date
    Jun 2004
    Posts
    195
    Images
    2
    The film advance mechanism for the 67 is the weak link of that camera IMO. I had at least three fail. They were all 67s, not the II, but I don't think much had changed with that part of the camera.

    The last time mine failed, it was on the top of Half Dome and the sunset that I missed capturing on the way down was one in a million. I hate to think of that happening to anyone...

    From my own observations about things that can affect its performance (outside of complete failure) are:

    1. The 120/220 dial not being fully engaged one way or the other
    2. The reset pin on the back door to the camera sticking
    3. Humidity causing the film to stick to the pressure plate
    4. The film release knobs not being fully engaged

    But, that said, it was most often wear and tear on the advance mechanism. Grime getting into the gears, too much eagerness to advance. Sounds as though you've been sufficiently dainty with it to keep it operating most of the time. I killed two with fast winds before I learned to go easy.

    Good luck.

  3. #3

    Join Date
    Jan 2007
    Shooter
    Medium Format
    Posts
    338
    Thanks for the great tips. All you said are very true for the Pentax 6x7 format cameras. I did look into these possibilities but found no solution so far. I am very sure the my film winder is not broken. It would act up only once or twice in shooting a roll of film. I have the 120/220 selector properly set. And it is not a pressure plate problem either. I am afraid that it may be related to the shutter. I don't know. The camera works perfectly otherwise. I will keep using it until it breaks or cures by itself.

  4. #4

    Join Date
    Apr 2004
    Location
    Montgomery, Il/USA
    Shooter
    Multi Format
    Posts
    5,709
    The action you describe is typical of a latch not returning to it's locking position. Since it's intermittent it's likely to be a dry pivot. A CLA should cure it, but if you can live with it, so much the better.
    Expletive Deleted!



 

APUG PARTNERS EQUALLY FUNDING OUR COMMUNITY:



Contact Us  |  Support Us!  |  Advertise  |  Site Terms  |  Archive  —   Search  |  Mobile Device Access  |  RSS  |  Facebook  |  Linkedin