Switch to English Language Passer en langue française Omschakelen naar Nederlandse Taal Wechseln Sie zu deutschen Sprache Passa alla lingua italiana
Members: 71,050   Posts: 1,561,106   Online: 851
      
Results 1 to 3 of 3
  1. #1

    Join Date
    Nov 2008
    Location
    Florence, Italy
    Shooter
    Multi Format
    Posts
    31

    SX70 exposure problem

    Hi all!
    Has anybody experience of what can be wrong with the light meter of a Polaroid Land camera SX 70? My camera always makes the same (long, let's say half second) exposure both in direct sunlight both in the dark... No difference moving the light/dark selector...
    Confusing...
    www.damianofedeli.it/english
    _______
    "I am a man, and nothing human is alien to me" (Terence, Latin dramatist)

  2. #2

    Join Date
    Jul 2008
    Location
    Horsham, PA
    Shooter
    Multi Format
    Posts
    751
    Does the shutter actually open for that long? I had a problem with my SX-70 where it took a while to take the shot, but it was always well exposed. It turns out that the capacitors were drained from years of non-use, and it took a while to get back up to speed. Another option if the photos come out well exposed is the battery being dead. Are you using Impossible or Polaroid film?
    "Panic not my child, the Great Yellow Father has your hand"--Larry Dressler

  3. #3

    Join Date
    Nov 2008
    Location
    Florence, Italy
    Shooter
    Multi Format
    Posts
    31
    Hi Nick, and thank you. Yes, the shutter opens for that long and all the pictures turn out overexposed, also rotating the light selector to the darkest setting. I am using new impossible film (with a fresh battery of course...)
    www.damianofedeli.it/english
    _______
    "I am a man, and nothing human is alien to me" (Terence, Latin dramatist)



 

APUG PARTNERS EQUALLY FUNDING OUR COMMUNITY:



Contact Us  |  Support Us!  |  Advertise  |  Site Terms  |  Archive  —   Search  |  Mobile Device Access  |  RSS  |  Facebook  |  Linkedin