Switch to English Language Passer en langue française Omschakelen naar Nederlandse Taal Wechseln Sie zu deutschen Sprache Passa alla lingua italiana
Members: 68,766   Posts: 1,484,141   Online: 780
      
Results 1 to 3 of 3
  1. #1

    Join Date
    Aug 2008
    Location
    Southern California
    Shooter
    35mm
    Posts
    46

    Polaroid 210 question

    I have a Polaroid 210 land camera that I have been using with a pack of Fuji instant film.

    I have heard that the springs that push down on the film packs often push down too hard and make it difficult to pull the paper strips without tearing when you are pulling the photograph out. I have experienced this several times so far and have had to retrieve the photo by opening the back up three times on a single pack.
    I think I've heard this is something that happens when you use Fuji film packs in Polaroid cameras.

    Is there a simple way to remedy this, or is there another problem with the camera?

    Thanks,
    DB

  2. #2
    Ektagraphic's Avatar
    Join Date
    Feb 2009
    Location
    Southeastern Massachusetts
    Shooter
    Multi Format
    Posts
    2,678
    Images
    23
    I have had some problems when using my 350. My others work very well.
    Helping to save analog photography one exposure at a time

  3. #3
    Alex Bishop-Thorpe's Avatar
    Join Date
    Jul 2006
    Location
    Adelaide, South Australia
    Shooter
    Multi Format
    Posts
    1,455
    Images
    29
    I had the same problem with my 350, but it seems to have gone away now. I did clean the rollers, but I dont think that should have made a difference mechanically.
    The Analogue Laboratory, or 'so you built a darkroom in an old factory in the industrial zone'.
    Blog thing!.

    Worry less. Photograph more.



 

APUG PARTNERS EQUALLY FUNDING OUR COMMUNITY:



Contact Us  |  Support Us!  |  Advertise  |  Site Terms  |  Archive  —   Search  |  Mobile Device Access  |  RSS  |  Facebook  |  Linkedin