Switch to English Language Passer en langue française Omschakelen naar Nederlandse Taal Wechseln Sie zu deutschen Sprache Passa alla lingua italiana
Members: 70,224   Posts: 1,532,568   Online: 1018
      
Page 1 of 2 12 LastLast
Results 1 to 10 of 20
  1. #1
    Sean's Avatar
    Join Date
    Aug 2002
    Location
    New Zealand
    Shooter
    Multi Format
    Posts
    8,553
    Blog Entries
    7
    Images
    15

    The APUG Blogs Rebuilt From The Ground Up! (previous blog entries still exist)

    Hi All,

    The first phase of the blog rebuild is complete. The blog area is open to the public and subscribers can create/comment on blogs. The previous system was pretty terrible. This new system is one of the more complex things I have ever put together for APUG. I've done some testing and it looks to be functioning OK. There is still more to come with the blog but this is a great start. I am currently putting together tutorials for using the blog. For the more adventurous going into your blog profile via the blog page and clicking the 'edit' tab allows you to configure several items. You can also add images into your blogs now, this is a little tricky but the basics are to click the image upload icon in your editor, browse to your file, upload your file - once your file is uploaded into the upload window there will be a link next to it to "add" it to your blog entry. There is attachment functionality as well.

    It is my intention to give Subscribers a nice blog area which they can link to on their personal websites. Also to have a nice area for Special Guest bloggers to blog.

    Please report any bugs here, I am sure there will be a few. Some new features:

    -total code upgrade
    -over 10 modules installed and configured
    -new theme installed and design tweaked + new graphics
    -wysiwyg editor (most browsers will allow you to create content in microsoft word like fashion)
    -blog image uploads (have images within your blog posts)
    -attachments working
    -full listing of active bloggers
    -ability to have a "My Links" block on your blogs page
    -guest book for your blog that visitors can sign
    -RSS for all blogs
    -RSS for individual blogs
    -Single login for blogs/apug
    -most recent blog entry shows in your apug forum profile
    -link to view your blog shows when your name is clicked in forum threads
    -spell check coming soon
    -image gallery capability coming soon

    Thanks,
    Sean
    Last edited by Sean; 02-25-2007 at 02:25 AM. Click to view previous post history.

  2. #2
    Bob F.'s Avatar
    Join Date
    Oct 2004
    Location
    London
    Shooter
    Multi Format
    Posts
    3,984
    Images
    19
    Seems to be a shortage of carriage returns - can not use the ENTER key to start a new line. Or to be precise, I can enter them in the editor but they do not display in the blog.

    Cheers, Bob.

  3. #3
    Sean's Avatar
    Join Date
    Aug 2002
    Location
    New Zealand
    Shooter
    Multi Format
    Posts
    8,553
    Blog Entries
    7
    Images
    15
    Hi Bob, what browser are you using, I'll give it a try. Sean

  4. #4
    Sean's Avatar
    Join Date
    Aug 2002
    Location
    New Zealand
    Shooter
    Multi Format
    Posts
    8,553
    Blog Entries
    7
    Images
    15
    no issues for me in Firefox, IE6 and Camino browsers. There could be issues in Safari as I think the editor in Safari is barely supported.. I have not been too happy with Safari and will try Safari again when version3 is out, until then I am on OSX Tiger with Firefox 2.0

  5. #5
    Bob F.'s Avatar
    Join Date
    Oct 2004
    Location
    London
    Shooter
    Multi Format
    Posts
    3,984
    Images
    19
    Quote Originally Posted by Sean View Post
    no issues for me in Firefox, IE6 and Camino browsers. There could be issues in Safari as I think the editor in Safari is barely supported.. I have not been too happy with Safari and will try Safari again when version3 is out, until then I am on OSX Tiger with Firefox 2.0
    Odd - I tried both Firefox 1.5 and IE 6... I'll restart my PC and try again.

    Cheers, Bob.

  6. #6
    Sean's Avatar
    Join Date
    Aug 2002
    Location
    New Zealand
    Shooter
    Multi Format
    Posts
    8,553
    Blog Entries
    7
    Images
    15
    ok, walk me through exactly what/how you typed and i'll try to reproduce it again. Thanks

    P.S. are you seeing the enhanced editor, it should look similar to microsoft word..

  7. #7
    Bob F.'s Avatar
    Join Date
    Oct 2004
    Location
    London
    Shooter
    Multi Format
    Posts
    3,984
    Images
    19
    Quote Originally Posted by Sean View Post
    ok, walk me through exactly what/how you typed and i'll try to reproduce it again. Thanks

    P.S. are you seeing the enhanced editor, it should look similar to microsoft word..
    Your PS was th clue I needed. Had to switch to "Full HTML" mode and edit the existing entry in that - that put the line feeds in.

    [edit]: Also when creating a new blog entry I have to use Full HTML mode to get the line feeds. Not a problem now I know.

    Cheers, Bob.

  8. #8
    jstraw's Avatar
    Join Date
    Aug 2006
    Location
    Topeka, Kansas
    Shooter
    Multi Format
    Posts
    2,703
    Images
    42
    Some observations, Sean:

    Since the APUG navigation is absent on the blogs (as I believe it should be) you are leaving APUG-proper as soon as you click on the "Blogs" tab. I think it should open in a new window because there's no easy navigation back except for the "Visit APUG.ORG" link.

    For me to want to make this the linked blog on my personal website I'd need the ability to alter the display name on the blog from my APUG username to my own name. I'd also need to be able to add a link to the rest of my website that's as prominant as the rest of the blog navigation and probably have it included in that navigation.
    Lorem ipsum dolor sit amet, consectetuer adipiscing elit. In velit arcu, consequat at, interdum sit amet, consequat in, quam.

  9. #9
    jstraw's Avatar
    Join Date
    Aug 2006
    Location
    Topeka, Kansas
    Shooter
    Multi Format
    Posts
    2,703
    Images
    42
    It seems that added user links only show on the blogs to people that are logged into APUG.

    Ack! I can't remove a link?
    Last edited by jstraw; 02-25-2007 at 09:17 AM. Click to view previous post history.
    Lorem ipsum dolor sit amet, consectetuer adipiscing elit. In velit arcu, consequat at, interdum sit amet, consequat in, quam.

  10. #10
    jstraw's Avatar
    Join Date
    Aug 2006
    Location
    Topeka, Kansas
    Shooter
    Multi Format
    Posts
    2,703
    Images
    42
    I just noticed that creating a user link on my blog shows up on the "Blog Homepage."

    I don't want every little thing I experiment with to appear there. I need to be able to create and use categories and "Blog Homepage" can be a category I use or don't use at my discretion.

    I also notice that the links to "Blog Homepage" and "Blog and Tutorial Help" go to the same Blog Homepage.

    I don't think this is ready for launch. I think this is not a beta yet...still alpha.

    I'm sorry Sean, there's a lot of good work here and it can be great but it's not ready to be live yet.
    Lorem ipsum dolor sit amet, consectetuer adipiscing elit. In velit arcu, consequat at, interdum sit amet, consequat in, quam.

Page 1 of 2 12 LastLast


 

APUG PARTNERS EQUALLY FUNDING OUR COMMUNITY:



Contact Us  |  Support Us!  |  Advertise  |  Site Terms  |  Archive  —   Search  |  Mobile Device Access  |  RSS  |  Facebook  |  Linkedin