Switch to English Language Passer en langue française Omschakelen naar Nederlandse Taal Wechseln Sie zu deutschen Sprache Passa alla lingua italiana
Members: 71,836   Posts: 1,582,436   Online: 705
      
Results 1 to 8 of 8
  1. #1

    Join Date
    Dec 2003
    Posts
    6

    Fuji Processing Mailers...address?

    I have many Fuji mailers with the Phoenix address on them. Should they still be mailed to Phoenix? Someone on another forum mentioned sending them to:
    Fujicolor Processing
    P.O. Box 837
    Parsons, KS 67357
    I am having trouble getting a definitive answer, and I haven't heard back from Fuji (emailed them). I may call them tomorrow, but I'm curious as to what you all might know.
    Thanks in advance!

  2. #2
    Dave Parker's Avatar
    Join Date
    Aug 2004
    Shooter
    Multi Format
    Posts
    4,049
    They need to be mailed to the Parsons, KS address Fuji has Dwanes doing their processing now, somebody on this fourm posted the new mailers address the other day, but again, the Parsons, KS is the correct address to send to.

    R.

  3. #3

    Join Date
    Dec 2003
    Posts
    6
    Thank you!

  4. #4

    Join Date
    Dec 2003
    Posts
    6
    Just got off the phone with Fuji...they said to use the Phoenix address. I guess that's what I'll do.

  5. #5
    copake_ham's Avatar
    Join Date
    Jan 2006
    Location
    NYC or Copake or Tucson
    Shooter
    35mm
    Posts
    4,092
    Images
    56
    I was the one who posted the notice I'd received on the "Availability" forum. It came with a box of slides that were shot with the now discontinuted ISO 50 Fujichrome.

    So perhaps Fuji was only referring to this film in instructing me to send it to Dwayne's? There was no further info on the notice - so I'm as confused as ever. I do have a bunch of "50" that I will send to Dwayne's but guess I'll still send the 100 etc. to Phoenix until I hear otherwise.

    I do note that the "50" slides were from a roll sent in over a month ago - so that it may well be that Fuji sent them to Dwyane's then back to Fuji and to me.

    Hopefully, Fuji will clarify that they only meant to send the 50 to Dwayne's and not all Fujichrome!

  6. #6
    Dave Parker's Avatar
    Join Date
    Aug 2004
    Shooter
    Multi Format
    Posts
    4,049
    That really don't make any sense, the ISO100 and ISO50 are processed the same, same machine, same chemistry, same time in the machine, so it would make no sense at all to send them to different processing facilities as the machine doing the E6 processing does not even sense what speed the film is, and if your pushing or pulling you have to change the machine to compensate for the times in the chemicals...hope they get it figured out...

    R.

  7. #7

    Join Date
    Dec 2003
    Posts
    6

    I sent them all!

    I had 30 rolls; mix of V50, V100, and ES100vs...I just sent it all in to Phoenix. Interestingly (or frustratingly) there is no link anywhere on Fuji's site that addresses processing. I emailed and got tired of waiting for a response, so I called. The service rep said send them to Phoenix, and futher that there were no plans to change this procedure in the works. Oh well...I'll let you know what happens.

  8. #8
    copake_ham's Avatar
    Join Date
    Jan 2006
    Location
    NYC or Copake or Tucson
    Shooter
    35mm
    Posts
    4,092
    Images
    56
    Quote Originally Posted by jbear
    I had 30 rolls; mix of V50, V100, and ES100vs...I just sent it all in to Phoenix. Interestingly (or frustratingly) there is no link anywhere on Fuji's site that addresses processing. I emailed and got tired of waiting for a response, so I called. The service rep said send them to Phoenix, and futher that there were no plans to change this procedure in the works. Oh well...I'll let you know what happens.
    I do think that sending the film to Phoenix will "work" in terms of getting your slides to you eventually. The "notice" did indicate that in order to avoid delays, as of July 1, 2006, you should send it directly to Dwayne's.

    Here is the link to my original post (with attachment) that I put on the Product Availability forum:

    http://www.apug.org/forums/forum172/29448-fujichrome-mailers-go-dwaynes.html



 

APUG PARTNERS EQUALLY FUNDING OUR COMMUNITY:



Contact Us  |  Support Us!  |  Advertise  |  Site Terms  |  Archive  —   Search  |  Mobile Device Access  |  RSS  |  Facebook  |  Linkedin