Switch to English Language Passer en langue française Omschakelen naar Nederlandse Taal Wechseln Sie zu deutschen Sprache Passa alla lingua italiana
Members: 70,287   Posts: 1,535,333   Online: 854
      
Results 1 to 5 of 5
  1. #1

    Join Date
    Jan 2011
    Location
    Long Island, New York
    Shooter
    Medium Format
    Posts
    19

    Problems/Questions in using Phototherm SSK-4

    I'm a serious amateur photographer living in Long Island, New York. I've bought a used Phototherm SSK-4, it just arrived this morning. I haven't bought any chemistry yet because both B&H and Adorama are closed for the holidays for over a week (How nice is it if somebody works there!!). I tried the processor out with water today and encountered several problems.

    1. Many times it can't detect the processing drum. But if I select "FLUSH", then "DRAIN", it then runs normally and I can select E6, C41... afterwards. Does anybody know why? The drum is securely locked in place. Do I have to drain it everytime before processing films?

    2. When I turn on the machine, I can select "E6 4S", "C41", "B&W", and so on... But I can't figure out how to choose E6 7-step. Only the "PLUS" and "START" buttons are responding. The purpose of buying this machine is mainly for E6. Can anybody help me on this?

    I've read the instruction manual several times and still can't figure that out. And since I work normal hours (9 ~ 5:30), I can't make a phone call to phototherm with the machine in front of me while I'm at home and phototherm's techician is at the office. Can somebody help me?

    Actually I've posted these questions on photo.net. I think APUG has more film enthusiasts who may give me a helping hand.

  2. #2

    Join Date
    Sep 2006
    Shooter
    35mm
    Posts
    134
    1: Never had this error, though it has been wobbly once or twice, but still ran. It just leaked some. The one I use just flushes automatically at the end of every run while its running the dryer. Drain I believe just drains whatever is being held in the tank and shouldn't have to be done first.
    2: Is it just chipped for the 4 step version possibly and not the 7? You may have to get a new one for that.

  3. #3

    Join Date
    Sep 2008
    Shooter
    Multi Format
    Posts
    747
    I'll check my manuals tonight. Mine is finicky about the drum sensor sometimes too. Usually reseating the drum or fiddling with the two metal needle-type sensor wires to make sure they are making contact cures it. It should be possible to program the 7-step if need be. I think holding down one of the buttons when turning on enables the programming mode where you can switch between E6 programs. Shoulnd't need to drain/flush before processing, I dont' think.

    It's a great unit, couldnt' be happier with mine!

    -Ed

  4. #4

    Join Date
    Sep 2006
    Shooter
    35mm
    Posts
    134
    Ah, I didn't see he had the SSK, Mine is only the normal non programmable version, so the chipping thing shouldn't be an issue.

  5. #5

    Join Date
    Jan 2011
    Location
    Long Island, New York
    Shooter
    Medium Format
    Posts
    19
    Thanks everyone. I found out how to set it to 7-step last night. As EdSawyer says, I need to turn off the unit, hold "start" and turn it on, get to the program mode, go through the manual until it shows E6, then set it to 7-step.

    The contact points are in place. I just don't know why I have to "flush" and "drain" it everytime before I start a process. I didn't touch anything, just let the machine flash & drain, then select a process, it just ran normally after all that. Several attemps, it still performs like this.



 

APUG PARTNERS EQUALLY FUNDING OUR COMMUNITY:



Contact Us  |  Support Us!  |  Advertise  |  Site Terms  |  Archive  —   Search  |  Mobile Device Access  |  RSS  |  Facebook  |  Linkedin