Switch to English Language Passer en langue française Omschakelen naar Nederlandse Taal Wechseln Sie zu deutschen Sprache Passa alla lingua italiana
Members: 69,985   Posts: 1,523,930   Online: 923
      
Page 3 of 3 FirstFirst 123
Results 21 to 23 of 23

Thread: LPL c7700

  1. #21

    Join Date
    Feb 2008
    Location
    Leamington spa, England
    Shooter
    35mm
    Posts
    29
    Yes it was the white powder and asked my dad what it was and he said it was insulating!

    So should i replace this VJ11M aswell or will it be ok as the light does work?

  2. #22

    Join Date
    Feb 2008
    Location
    Leamington spa, England
    Shooter
    35mm
    Posts
    29
    There were two last-minute bids, one at £80 and one at £99.99
    I just assumed it was the same person as the bid was uped a few seconds later! Sorry, so correction £15 lol.

  3. #23
    RH Designs's Avatar
    Join Date
    Apr 2003
    Location
    Yorkshire Dales, England
    Shooter
    Multi Format
    Posts
    657
    Images
    18
    Quote Originally Posted by Shakey View Post
    Yes it was the white powder and asked my dad what it was and he said it was insulating!

    So should i replace this VJ11M aswell or will it be ok as the light does work?
    It's usually the lamp pins that corrode rather than the socket I think. I had a similar problem with an old Meopta but the new lamp seemed to work fine. With the new lamp in place, you could try gently wobbling the socket a little to see if there's any flicker, but be careful and quick because it will all get very hot pretty quickly!
    Regards,
    Richard.

    RH Designs - My Photography

Page 3 of 3 FirstFirst 123


 

APUG PARTNERS EQUALLY FUNDING OUR COMMUNITY:



Contact Us  |  Support Us!  |  Advertise  |  Site Terms  |  Archive  —   Search  |  Mobile Device Access  |  RSS  |  Facebook  |  Linkedin