Switch to English Language Passer en langue française Omschakelen naar Nederlandse Taal Wechseln Sie zu deutschen Sprache Passa alla lingua italiana
Members: 68,677   Posts: 1,482,023   Online: 883
      
Results 1 to 5 of 5
  1. #1

    Join Date
    Mar 2009
    Location
    Ireland
    Shooter
    Medium Format
    Posts
    3

    Problem with De Vere 5x7 closed-loop colour head

    Hi everyone,

    This is my first post on APUG and I'm hopeful that someone will have answers to my questions since I've seen the collective wisdom that's out there.

    I recently bought a second-hand De Vere 507 enlarger with the closed-loop colour head and installed it in a shed that I've been converting into a darkroom over the past while. It worked very well initially but I think that it has succumbed to the dampness in Ireland because when I switched it on recently, there was a bit of buzzing and flashing from within the head and, since then, it's no longer working properly. The two lamps are still lighting but the internal shutter doesn't open any longer and the filters seem to be parked rather than moving when adjusted from the remote keypad. The message on the keypad is that the lamps are blown but I think that the sensor is simply not seeing the light, so to speak, since the shutter and filters are seized.

    My questions concern repair of the head. Is it an operation that one could consider doing oneself or is it a job for a pro? Should I try to get it fixed by an electronics handyman or just bite the bullet and send it to Odyssey in the UK? Have any of you had similar experience with the closed-loop head? Perhaps I should give up on this head as being too complicated? I shoot B&W only, up to 5x4. Can more commonly available 5x4 heads be fitted to this enlarger?

    Lots of questions so thanks in advance,

    Conor.

  2. #2
    Bob Carnie's Avatar
    Join Date
    Apr 2004
    Location
    Toronto-Ontario
    Shooter
    Med. Format RF
    Posts
    4,538
    Images
    11
    Send it to a pro.

  3. #3
    Mark Antony's Avatar
    Join Date
    Mar 2007
    Location
    East Anglia,UK
    Shooter
    Multi Format
    Posts
    772
    Images
    38
    I'd give the guys from odyssey a call, they'll give you advice on what may have happened and if it can be self fixed and how to avoid it happening again.
    http://www.odyssey-sales.com/
    01273 676768

  4. #4
    JimO's Avatar
    Join Date
    Dec 2008
    Location
    left coast of the east coast - FL, USA
    Shooter
    Medium Format
    Posts
    289

    friend had one

    a friend had a devere... liked it and found it reliable. he remarked one time, that if anything ever went wrong with it, you gotta have someone who knows what they're doing repair it - because of the electronics!

  5. #5

    Join Date
    Mar 2009
    Location
    Ireland
    Shooter
    Medium Format
    Posts
    3
    Thanks,

    I called Odyssey who said that I should send the head to them and that only once they looked at it could they tell me how much repair would cost. However, they did mention that a 5x4 head can be used on the 5x7 chassis, so I might look at that as a cheaper and more robust solution than getting the closed loop head repaired.

    Conor.



 

APUG PARTNERS EQUALLY FUNDING OUR COMMUNITY:



Contact Us  |  Support Us!  |  Advertise  |  Site Terms  |  Archive  —   Search  |  Mobile Device Access  |  RSS  |  Facebook  |  Linkedin