Switch to English Language Passer en langue française Omschakelen naar Nederlandse Taal Wechseln Sie zu deutschen Sprache Passa alla lingua italiana
Members: 70,295   Posts: 1,535,673   Online: 1159
      
Results 1 to 4 of 4
  1. #1
    delphine's Avatar
    Join Date
    Jun 2007
    Location
    London (UK)
    Shooter
    Medium Format
    Posts
    628
    Images
    13

    Ilford 500 head - Anti heat filter problem

    Hello all,

    I have a problem with my Ilford 500 head and I hope that some of you set me on the right track.
    I'll save you a long boring story of a blown up halogen bulb, lots of bad karma and a broken color filter.

    Replacing my filters in the filter holder, after cautiously unscrewing the two halves of the holder to insert the filters and re-screwing them ever so cautiously, I have a problem with the anti heat filter. It won't stay in the grooves and it keeps on falling off. I must add that the holder is tight after re-screwing. It is as if the grooves of the anti heat filter were slightly too far apart to hold the filter in place.

    What would you recommend I do? Do you think that I could insert something in the grooves to help hold the anti heat filter? I am obviously concerned about the heat generated by the bulb, and whether in doing so I would not make a matter worse.

    Any advise welcome. Could I be really the only one with this problem?

    Best

    Dee

  2. #2
    Mike Wilde's Avatar
    Join Date
    Aug 2006
    Location
    Misissauaga Canada
    Shooter
    Multi Format
    Posts
    2,939
    Images
    29
    it is probably designed to be somewhat loose in the holder by design, so that it can expand as it absorbs the ehat it is suppose to do.


    I am not familiar with the head in question. Is there any chance some part of the flange that surronds the filter has been bebt and is thus not quite as tight as it may have once been?

    The other possibility - is there a bevel on the edge of the filter, and hence an up or down side?

    My only experiencce with said glass in a loose state was in a beselar 23 many years ago.

    I printed EP/2 with acetate filters, and the heat resistant piece sat in the top slot of the filter drawer, and the acetate stack lived in the bottom stack.
    my real name, imagine that.

  3. #3
    George Nova Scotia's Avatar
    Join Date
    Mar 2010
    Location
    Nova Scotia Canada
    Shooter
    Multi Format
    Posts
    444
    Images
    9
    No you're not the only one that's had to replace those filters. Check out this thread http://www.apug.org/forums/forum43/9...g-glass-3.html

    After some time I did manage to get new filters from someone in England. Until now I haven't tried to put them in, but I just did and one seems to fit okay. It is loose and free to move but I don't see how it would fall out. You might to double check the size of the filter it should be 15x30mm. If I get a chance tomorrow I might give it try and put mine back together to see if anything shows up.

  4. #4
    delphine's Avatar
    Join Date
    Jun 2007
    Location
    London (UK)
    Shooter
    Medium Format
    Posts
    628
    Images
    13
    Hi George,

    Actually I am not struggling to replace the HA filters. I have them. The problem is that the filter does not hold in the grooves.
    That's true that there is a bevel. So may be there is a up and down side as Mike suggests.

    Please do let me know if you had any additional ideas after you inspect your head.

    Best

    Delphine



 

APUG PARTNERS EQUALLY FUNDING OUR COMMUNITY:



Contact Us  |  Support Us!  |  Advertise  |  Site Terms  |  Archive  —   Search  |  Mobile Device Access  |  RSS  |  Facebook  |  Linkedin