Switch to English Language Passer en langue française Omschakelen naar Nederlandse Taal Wechseln Sie zu deutschen Sprache Passa alla lingua italiana
Members: 70,577   Posts: 1,545,719   Online: 791
      
Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1

    Join Date
    Apr 2013
    Shooter
    Medium Format
    Posts
    30

    Beseler 45s delay

    im sorry if this has been answered, but ive yet to find a thorough answer to the delay in the 45s. when i power mine on it takes several seconds, even up to 10 seconds to turn on. ive contacted beseler several times and theyre horribke to get a hold of.
    does anyone have a copy of the service manual or schematic?
    if so pm me please

  2. #2
    David Brown's Avatar
    Join Date
    Feb 2004
    Location
    near Dallas, TX USA
    Shooter
    Medium Format
    Posts
    3,303
    Images
    6
    ...
    Last edited by David Brown; 04-26-2013 at 02:56 PM. Click to view previous post history. Reason: I referred the OP to his own post ... (Doh!)

  3. #3

    Join Date
    Apr 2013
    Shooter
    Medium Format
    Posts
    30
    Quote Originally Posted by David Brown View Post
    ...

    so i take it by the edit that you don't know about a fix for this?

  4. #4

    Join Date
    Apr 2013
    Shooter
    Multi Format
    Posts
    133
    Quote Originally Posted by killahound22 View Post
    so i take it by the edit that you don't know about a fix for this?
    I think what he means is that you've got 2 threads going on this. The other one seems to have more hits. Be patient--there's some good minds on here. Give them time to log on and read the new posts. In the meantime, search the archives. Since I have seen no schematic, I can't even give a good guess.

  5. #5

    Join Date
    Apr 2013
    Shooter
    Medium Format
    Posts
    30
    Quote Originally Posted by HTF III View Post
    I think what he means is that you've got 2 threads going on this. The other one seems to have more hits. Be patient--there's some good minds on here. Give them time to log on and read the new posts. In the meantime, search the archives. Since I have seen no schematic, I can't even give a good guess.

    i only got 1 thread. i tried to revive a dead thread

  6. #6
    David Brown's Avatar
    Join Date
    Feb 2004
    Location
    near Dallas, TX USA
    Shooter
    Medium Format
    Posts
    3,303
    Images
    6
    Quote Originally Posted by killahound22 View Post
    i only got 1 thread. i tried to revive a dead thread
    I own and use a 45S but have never experienced this problem. I originally referred you to the "dead thread" (see: "reason for edit") because it had the only answer that I know of. The symptom you describe is not normal, but it has been heard of. The solution usually requires replacing a part, as was stated in that thread. Sorry I don't have any more details, but since you had revived that thread, I assumed you had read that answer.

  7. #7

    Join Date
    Apr 2013
    Shooter
    Medium Format
    Posts
    30
    Quote Originally Posted by David Brown View Post
    I own and use a 45S but have never experienced this problem. I originally referred you to the "dead thread" (see: "reason for edit") because it had the only answer that I know of. The symptom you describe is not normal, but it has been heard of. The solution usually requires replacing a part, as was stated in that thread. Sorry I don't have any more details, but since you had revived that thread, I assumed you had read that answer.


    I know the answer. But I need a solution on the repair, location of the opti isolator possibly pics of where it is on the pc board. And what exactly we are swapping and where to get a proper replacement.

  8. #8

    Join Date
    Dec 2012
    Location
    Kentucky
    Shooter
    Large Format
    Posts
    220
    Hate to be a wet blanket but without an actual schematic and some reasonable test equipment you are asking for more problems than you are starting with. Replacing a bad opto isolator or other micro miniature electronic component is not plugging in a new tube like the by gone days. Should be done in proper static control environment with appropriate anti static tools. 1 Meg ohm to real earth ground +/-10% for the work surface and 40 - 60 % relative humidity.

  9. #9

    Join Date
    Apr 2013
    Shooter
    Multi Format
    Posts
    133
    I wonder if not a regular Variac off fleabay would work.

  10. #10

    Join Date
    Apr 2013
    Shooter
    Medium Format
    Posts
    30
    Quote Originally Posted by gleaf View Post
    Hate to be a wet blanket but without an actual schematic and some reasonable test equipment you are asking for more problems than you are starting with. Replacing a bad opto isolator or other micro miniature electronic component is not plugging in a new tube like the by gone days. Should be done in proper static control environment with appropriate anti static tools. 1 Meg ohm to real earth ground +/-10% for the work surface and 40 - 60 % relative humidity.
    i'm not an idiot, i have my own shop where i do stuff like this regularly. I understand that i need a schematic, that's why i'm patiently waiting that someone can [virtually] dust off one their folders in their computer and email me that service manual or schematic.
    Beseler, those greedy bastards, charge $75 for the service manual. Absolute insanity, for an item they longer support..

Page 1 of 2 12 LastLast


 

APUG PARTNERS EQUALLY FUNDING OUR COMMUNITY:



Contact Us  |  Support Us!  |  Advertise  |  Site Terms  |  Archive  —   Search  |  Mobile Device Access  |  RSS  |  Facebook  |  Linkedin