Switch to English Language Passer en langue française Omschakelen naar Nederlandse Taal Wechseln Sie zu deutschen Sprache Passa alla lingua italiana
Members: 70,966   Posts: 1,558,422   Online: 952
      
Page 1 of 3 123 LastLast
Results 1 to 10 of 22
  1. #1
    Greg Davis's Avatar
    Join Date
    Feb 2004
    Location
    Crestview Hills, KY
    Shooter
    8x10 Format
    Posts
    1,939

    For those of you that design circuits...

    I have two identical magnetic stirrer/hotplates that do not work. One will run for a couple minutes then shut off completely until I remove the fuse and put it right back in, the other does absolutely nothing at all. Looking inside, the power comes in, goes to a circuit board then the motor and hotplate. The two dial switches are on a separate circuit board. Nothing looks damaged, in fact, they look brand new on the inside.

    I do not need the hotplate function, so I was thinking that I may be able to bypass the PCB's altogether and wire the dial potentiometer directly to the motor and power. Testing if the motor was any good, I disconnected it from it's PCB and connected it straight to the power cord inlet and it worked just fine, though at full speed only. I know only the basic concepts of circuits, so I do not know if I need to have any resistors or things so I don't fry the motor or switch. My question to you all is, what do I need to read with my multimeter to find out the limits of the switch and motor, then calculate what parts I may need in between. The device does say it uses a 10A fuse and is 125V. If any of you have an iPhone or iPad, I can "FaceTime" with you and check things in real time.
    www.gregorytdavis.com

    Did millions of people suddenly disappear? This may have an answer.

    "No one knows that day or hour, not even the angels in heaven, nor the Son, but only the Father." -Matthew 24:36

  2. #2

    Join Date
    Mar 2007
    Location
    Ottawa, Canada
    Shooter
    Medium Format
    Posts
    152
    Images
    8
    If you don't need the hotplate, just disconnect it from the PCB and leave the motor connected to the PCB. It seems that the motor speed is electronically controlled. The shut down after a few minutes could be a self protection circuit kicking in. Maybe the hotplate draws too much current due to a defect. Taking the fuse out and put it back in (or just disconnecting it from the 120V) probably resets the protection circuit.

  3. #3

    Join Date
    Dec 2010
    Location
    Outside Boston, MA
    Shooter
    35mm
    Posts
    183
    Yeah, if the motor is electronically controlled, you DO NOT want to just put the pot between the motor and the line. The pot is rated for very low power and will turn into smoke if you try that. The problem is with something on the electronic control board. If you can send a pic of that I might be able to tell you what to replace.

    Are these Chinese made or from a major manufacturer? (I'm looking here for two things: quality of design and possibility of IDing the parts)

    There's also the junkyard challenge alternative of replacing the whole motor control circuit with an off-the-shelf lamp dimmer...
    Last edited by Peter Simpson; 07-16-2013 at 12:46 PM. Click to view previous post history.

  4. #4
    Greg Davis's Avatar
    Join Date
    Feb 2004
    Location
    Crestview Hills, KY
    Shooter
    8x10 Format
    Posts
    1,939
    This is the one day I didn't bring my digital camera to take photos of this with. I will see what I can do in the meantime. The one that works intermittently does this whether the hotplate is on or off. Unplugging it from the wall and back in does not make it work again. The PCB with the switches has only three small resistors connected to led bulbs, otherwise it doesn't have anything on it. It is connected to the main PCB by a ribbon cable.

    The units are Fisher Scientific brand, but they are a discontinued model of their Isotemp series.
    www.gregorytdavis.com

    Did millions of people suddenly disappear? This may have an answer.

    "No one knows that day or hour, not even the angels in heaven, nor the Son, but only the Father." -Matthew 24:36

  5. #5
    jp498's Avatar
    Join Date
    Oct 2009
    Location
    Owls Head ME
    Shooter
    Multi Format
    Posts
    1,467
    Images
    74
    Make as few changes as possible to achieve your goal, especially as you don't know what you're doing and it's 120v. I'd suggest just removing the heating element.

    The heating and cooling and motion could have also caused circuit board pads to lift (where wires or components are soldered on); in which case you'd have to repair those with resoldering or bypassing torn traces with wire jumpers)

    You could also find some retired appliance repairman in your community if it's that simple. It used to be a common profession before appliance were made disposable.

  6. #6
    Greg Davis's Avatar
    Join Date
    Feb 2004
    Location
    Crestview Hills, KY
    Shooter
    8x10 Format
    Posts
    1,939
    Well, I have done some troubleshooting with it. The heating element is disconnected, but the problem persists. Since they are identical, I thought I would see if I could eliminate some possibilities. The motors of both work, and I swapped the switch PCB's with no change. The first unit still turns on for a while, the second doesn't come on at all. The main PCB has a part that touches the machine's frame with a thermal paste. If it is not in contact with the frame, then the motor only spins at it's fastest speed regardless of the speed setting. I replaced the thermal paste with fresh paste, but no change. I used an infrared laser thermometer to see if any part may be overheating. One small part circled here gets hot. The thing seems to turn off when this piece reaches 140 F, which only happens if I use a medium to slow speed on the motor. It gets hot at higher speed, but not hot enough that the motor shuts off.
    Attached Thumbnails Attached Thumbnails photo.JPG  
    www.gregorytdavis.com

    Did millions of people suddenly disappear? This may have an answer.

    "No one knows that day or hour, not even the angels in heaven, nor the Son, but only the Father." -Matthew 24:36

  7. #7

    Join Date
    Dec 2010
    Location
    Outside Boston, MA
    Shooter
    35mm
    Posts
    183
    OK, Fisher Scientific is probably worth fixing. One more thing that I should have said at the start: be VERY VERY CAREFUL if this thing is open and you apply power. IT CAN KILL YOU.

    The circled part is a low voltage DC capacitor and it shouldn't be getting to 140F. But that's probably a result, not the cause of your problem.

    The heating coil might be independent of everything but I wouldn't assume that disconnecting it won't affect other stuff on that circuit board.
    You can try Googling for a schematic with the exact model number, it's a slim hope, but you might get lucky. I would pull the thing apart and try to reverse engineer the AC control side of the board and figure out whether the DC supply is still working. Those are the two most likely problem areas. My guess is it might have gotten zapped -- this is a risk for anything that stays plugged in all the time. A second possibility is that something overheated.

    The white things by your thumb look to be opto couplers, used to isolate logic circuits from AC circuits. The bent over part with heatsink goop on it just to the right is probably the Triac that controls motor speed or hotplate temp...there should be a second one somewhere...again, can't tell how the hotplate is controlled -- is it a separate, independent control, or does it connect to that board as well?

    If you can get a good clean shot of both sides of the circuit board, and then annotate what connects to each of those wires, I might be able to do this by remote control. You can PM me, no need to clutter up this thread until we figure out what's wrong.

  8. #8
    Greg Davis's Avatar
    Join Date
    Feb 2004
    Location
    Crestview Hills, KY
    Shooter
    8x10 Format
    Posts
    1,939
    In the photo, the black cloth covered wires go to the motor, the white ones connect to the heating element. It is controlled by a separate dial, but it connects to the same PCB as the motor.
    www.gregorytdavis.com

    Did millions of people suddenly disappear? This may have an answer.

    "No one knows that day or hour, not even the angels in heaven, nor the Son, but only the Father." -Matthew 24:36

  9. #9
    Steve Smith's Avatar
    Join Date
    May 2006
    Location
    Ryde, Isle of Wight
    Shooter
    Medium Format
    Posts
    8,614
    Images
    122
    Unfortunately this is one of those things which many of us could sort out in minutes if we had it in front of us but is nearly impossible to sort out remotely. You need to find someone local who knows about these things.


    Steve.
    "People who say things won't work are a dime a dozen. People who figure out how to make things work are worth a fortune" - Dave Rat.

  10. #10

    Join Date
    Dec 2010
    Location
    Outside Boston, MA
    Shooter
    35mm
    Posts
    183
    OK, looks like there's another triac just above your circled part -- it's a surface mount part, lower power capacity, which makes sense. The big one with the thermal paste on it must be for the heater control. Either or both of those could be blown, or it could be that the micro (I'm guessing it's just to the left of the transformer, but that photo isn't quite high enough res for me to read the part numbers) is shutting things down.

    First thing is to see if the DC supply is working OK -- is the micro getting 5V or 3.3V? There's a bridge rectifier marked BR1 just above the top left corner of the transformer. That probably feeds the fat cap to its right and the chip above it is marked VR1, for Voltage Regulator. There should be a regulated DC output from that chip, which will power the control logic. I'll bet your thermometer measured VR1 instead of the cap above it. What's the big silver and black thing on the edge of the PCB, just to the right of your circled cap?

Page 1 of 3 123 LastLast


 

APUG PARTNERS EQUALLY FUNDING OUR COMMUNITY:



Contact Us  |  Support Us!  |  Advertise  |  Site Terms  |  Archive  —   Search  |  Mobile Device Access  |  RSS  |  Facebook  |  Linkedin