Switch to English Language Passer en langue française Omschakelen naar Nederlandse Taal Wechseln Sie zu deutschen Sprache Passa alla lingua italiana
Members: 70,524   Posts: 1,543,818   Online: 790
      
Results 1 to 4 of 4
  1. #1

    Join Date
    Feb 2004
    Location
    virginia beach, va
    Posts
    22

    using a strobe with my Kodak portrait lens

    Hi All, I'm trying to figure out if it's possible to get my strobe sync cords to work with this old lens on my 8x10. It has an old two pronged thing. Not a modern pc terminal. Is there a work around or cord adapter?

    Thanks
    Echard

  2. #2

    Join Date
    Jun 2003
    Location
    local
    Shooter
    Multi Format
    Posts
    16,286
    Blog Entries
    4
    Images
    49
    paramount makes ( still ) a a 2 prong syc that you can probably find online, here in the classifieds
    or get special ordered for you at your local photo store.

    http://paramountcords.com/Bipost.asp

    ( or directly through paramount )

    have fun!

    john
    silver magnets, trickle tanks sold
    artwork often times sold for charity
    PM me for details

  3. #3

    Join Date
    Feb 2004
    Location
    virginia beach, va
    Posts
    22
    Nice! Thanks John!

    Cheers,
    Echard

  4. #4
    jp498's Avatar
    Join Date
    Oct 2009
    Location
    Owls Head ME
    Shooter
    Multi Format
    Posts
    1,467
    Images
    74
    Small alligator clips will work too if you don't want to wait for a cord to show up. I'm also told the ilex5 shutter it uses doesn't have a detent for the x-sync setting, so one should fire it with strobes hooked up while observing the ground glass to make sure the x-sync setting is selected.



 

APUG PARTNERS EQUALLY FUNDING OUR COMMUNITY:



Contact Us  |  Support Us!  |  Advertise  |  Site Terms  |  Archive  —   Search  |  Mobile Device Access  |  RSS  |  Facebook  |  Linkedin