Switch to English Language Passer en langue française Omschakelen naar Nederlandse Taal Wechseln Sie zu deutschen Sprache Passa alla lingua italiana
Members: 70,571   Posts: 1,545,596   Online: 985
      
Results 1 to 7 of 7
  1. #1

    Join Date
    Aug 2005
    Location
    East Marion, NY, USA
    Shooter
    Multi Format
    Posts
    348

    Fujica GW690 - Wobbly Shutter Speed Ring

    Hi guys and gals,

    I took my GW690 out of the camera bag after returning from a photo trip, and noticed that the lens didn't feel right.

    If I put my fingers on the shutter speed ring and rock it back and forth, it wobbles, so that the tiny space between the shutter speed ring and the aperture ring gets larger and smaller.

    I can still change the shutter speeds, and they still seem to be accurate. It's like the front of the lens has come slightly unglued, or unscrewed. It feels like a loose filter that wants to be tightened, but of course there's nothing to turn to tighten it.

    Anyone seen something like this with your GW or GWS?
    "What drives man to create is the compulsion to, just once in his life, comprehend and record the pure, unadorned, unvarnished truth. Not some of it; all of it."

    - Fred Picker

  2. #2

    Join Date
    Nov 2007
    Location
    Tacoma, WA
    Shooter
    Multi Format
    Posts
    560
    Does it rock when you put your hands on the front element and rock it back and forth? I have a Fujinon 125mm SW (big large format wide angle lens) and the front element has a very slight play. Apparently something on the shutter mount cracked.

  3. #3

    Join Date
    Aug 2005
    Location
    East Marion, NY, USA
    Shooter
    Multi Format
    Posts
    348
    If I place my thumb on the top and my middle finger on the bottom of the shutter speed ring, I can rock it back and forth by pressing down with my thumb, or pulling up with my finger.
    "What drives man to create is the compulsion to, just once in his life, comprehend and record the pure, unadorned, unvarnished truth. Not some of it; all of it."

    - Fred Picker

  4. #4
    lxdude's Avatar
    Join Date
    Apr 2009
    Location
    Redlands, So. Calif.
    Shooter
    Multi Format
    Posts
    6,657
    Quote Originally Posted by seadrive View Post

    It's like the front of the lens has come slightly unglued, or unscrewed.
    Had a GF like that. If she was unscrewed, she'd come slightly unglued.
    I do use a digital device in my photographic pursuits when necessary.
    When someone rags on me for using film, I use a middle digit, upraised.

  5. #5

    Join Date
    Jul 2009
    Shooter
    Medium Format
    Posts
    543
    The front lens group simply unscrews from the lens mount- at least on my GW690, first model (no lens hood). Just to the front of the shutter ring is a thin- 2mm? black ring. If you can get a grip on this, the whole front group unscrews- many many threads, maybe 6mm of distance? Go slow, over soft surface, etc. in case it drops. Try a rubber pad to grip the outer edge of the lens?

    Inside are three small screws around the outer edge of a flat flange, going into a brass plate. These screws hold the shutter dial in place, best as I can tell. Well, I am not going to unscrew them just for fun, but the shutter dial is the same piece as what these screws hold. I bet your screws have come loose. A little tightening might solve the dial issue.

  6. #6

    Join Date
    Aug 2005
    Location
    East Marion, NY, USA
    Shooter
    Multi Format
    Posts
    348
    Thanks Dan, I'll give that a try.
    "What drives man to create is the compulsion to, just once in his life, comprehend and record the pure, unadorned, unvarnished truth. Not some of it; all of it."

    - Fred Picker

  7. #7

    Join Date
    Sep 2010
    Location
    Switzerland
    Shooter
    35mm
    Posts
    376
    Blog Entries
    1
    Images
    28
    Quote Originally Posted by lxdude View Post
    Had a GF like that. If she was unscrewed, she'd come slightly unglued.
    I see what you did there


    I've never had that problem with my GW690. If it really bothers you, I'd have it CLA'd.
    And the sign said, "long haired freaky people need not apply"



 

APUG PARTNERS EQUALLY FUNDING OUR COMMUNITY:



Contact Us  |  Support Us!  |  Advertise  |  Site Terms  |  Archive  —   Search  |  Mobile Device Access  |  RSS  |  Facebook  |  Linkedin