Switch to English Language Passer en langue française Omschakelen naar Nederlandse Taal Wechseln Sie zu deutschen Sprache Passa alla lingua italiana
Members: 70,966   Posts: 1,558,430   Online: 968
      
Results 1 to 7 of 7
  1. #1

    Join Date
    Sep 2012
    Location
    Luxembourg
    Shooter
    35mm
    Posts
    4

    hasselblad 2000 fcm

    hi,
    i´m new to this forum, so i hope im writting in the right thread.
    i just got into medium format film photography and got a hasselblad 2000 fcm, and it seems to work fine except for two main parts. first, the shutter does not retract when i take of the back. is that something i should be worried about? or was that just a feature to protect the shutter curtain?
    second, after i took a shot, the crank arm to advance the film wont turn, except if press the red button. can anyone help me to fix that?

    your help would be much apreciated!
    Laurent

  2. #2
    gorbas's Avatar
    Join Date
    Dec 2007
    Location
    Vancouver, BC, Canada
    Shooter
    35mm Pan
    Posts
    324
    Hi Laurent, It's normal for shutter to retract when magazine is removed (as safety measure). When you put magazine back to the body, then press button in middle of advance crank and advance. That way you are not waisting one frame of the film, but be sure that you keep dark slide in magazine until shutter is in cocked position.
    Sorry, no idea about your second question. Sounds strange??? Are you talking about button with red dot in the middle of advancing crank? After exposure you should be able to advance film with out any additional operations or button pressing.
    And sometime that huge shutter will be not retracted and it's scary feeling, especially knowing that is now almost impossible to fix it.
    Goran
    Last edited by gorbas; 09-07-2012 at 10:14 AM. Click to view previous post history. Reason: editing

  3. #3

    Join Date
    Sep 2012
    Location
    Luxembourg
    Shooter
    35mm
    Posts
    4
    hi Goran, thanks for your reply.
    yes i know that the shutter retracts normally, but mine does not... and since im new to these cameras i am a bit lost.
    and yes the arm only moves when i press the red button that you emntioned, which does not advance the film, so for the moment i can not use the camera

  4. #4

    Join Date
    Sep 2005
    Shooter
    Medium Format
    Posts
    28
    try this. With the back removed you will see a tab at the upper right corner, slide it to the right this should open the shutter when you remove the back the next time. On the crank, using a dime inserted into the slot and depressing the red button turn it to a different numbered position, and then try releasing the shutter.

  5. #5
    gorbas's Avatar
    Join Date
    Dec 2007
    Location
    Vancouver, BC, Canada
    Shooter
    35mm Pan
    Posts
    324
    Hi Laurent, l'm using 2000 FCW model and maybe there are some minimal operational difference between this two models. Do you have fresh battery in the camera? Did you try to operate camera with out the lens? What kind of lenses for your have on the camera? C, CF or F? Do you have manual for the camera?
    I just tried my camera and with out battery it behaves in similar way that you described.
    Did you try shutter setting "C" (for using C lenses with this camera) in that case camera body shutter works just as secondary (as in 500cm), the main shutter is in the lens. 3 setting in the middle of advance crank are just for different modes of mirror operation.
    Good luck! Please let me know if you need operational manual.
    Goran

  6. #6

    Join Date
    Sep 2012
    Location
    Luxembourg
    Shooter
    35mm
    Posts
    4
    thanks for you advice tony, but unfortunatley it does not work... i think the camera might need some repair. im in touch with a guy calles john emmet from london who might be able to help me!

  7. #7

    Join Date
    Sep 2012
    Location
    Luxembourg
    Shooter
    35mm
    Posts
    4
    yes i replaced the batteries when i got the camera. yes i used it without lens and the shutter neverretracts, not even for exposure.
    i got the carl zeiss 80mm 2.8 planar lens with the camera
    yeah i got the manual, i found it online.
    i got in touch with the guy who sold it to me to either refund me or pay for the repair of the camera, for all i have read on the internet so far, it seems that the camera is broken and he clearly stated that it is in excellent working condition

    i thank you for your help though! much apreciated!



 

APUG PARTNERS EQUALLY FUNDING OUR COMMUNITY:



Contact Us  |  Support Us!  |  Advertise  |  Site Terms  |  Archive  —   Search  |  Mobile Device Access  |  RSS  |  Facebook  |  Linkedin