Switch to English Language Passer en langue française Omschakelen naar Nederlandse Taal Wechseln Sie zu deutschen Sprache Passa alla lingua italiana
Members: 68,766   Posts: 1,484,113   Online: 949
      
Results 1 to 5 of 5
  1. #1
    altair's Avatar
    Join Date
    Mar 2009
    Location
    Kuala Lumpur, Malaysia
    Shooter
    Multi Format
    Posts
    392

    Koni Rapid Omega 100 gridlines 'unstuck'

    Hi everyone.

    Today I received in the mail a Koni Omega Rapid 100 with 3 lenses. Sweet, except when I looked through the viewfinder, I saw that the luminous gridlines that's visible in the viewfinder has somehow become 'unstuck', or more accurately, it appears to have come 'unglued'. It is now lying askew and has titled on its side. When I shake the camera or tap the front of the camera, I can see the gridlines moving around in there, in every which way. Sometimes it almost returns to it's original & correct position, but almost is as good as it gets. Then it starts moving around & tilting this way & that again. However, when I turn the focusing knob, I can see the gridlines moving accordingly as to correct for parallax. At least that's still working somewhat. Other than that, how will I compose anything with the gridlines the way it is?

    I'm guessing that the gridlines are on a piece of plastic or thin glass & this has somehow come undone. I don't know what could've caused it. I have another Rapid Omega 100 camera body & the gridlines in that one are working properly & stays in place. The rangefinder is way out, though.

    Anyone experienced this before? Pretty weird, I know. But worth asking anyway. If yes, what can I do to repair it?

    I paid a small fortune for this kit (in postgraduate student's terms), and having it turn out this way is pretty frustrating.

    Any help would be appreciated, thanks in advance.

    -Dani

  2. #2
    Barry S's Avatar
    Join Date
    Jan 2007
    Location
    DC Metro
    Shooter
    Large Format
    Posts
    1,200
    Images
    31
    Hi Dani--

    The gridlines are projected by a set of thin metal plates with slots. The plates are in a simple spring-loaded assembly that adjusts the framelines to compensate for parallax. I had to fix it on one of my Rapid Omega 100s and the problem was a spring that had become unclipped. The top cover is easily removed with three screws and you can probably figure out the fix.


  3. #3
    altair's Avatar
    Join Date
    Mar 2009
    Location
    Kuala Lumpur, Malaysia
    Shooter
    Multi Format
    Posts
    392
    Thank you Barry. I'll try to do this soon. Two questions before I do:

    a) With my previous Rapid Omega 100, I had great trouble taking those 3 screws off. They were too tight, or maybe I didn't use the right tool. Anyway, what can I use to loosen up the screws...will Liquid Wrench work? How about WD40?

    b) Once I have the top cover off and I've re-clipped the spring that came off, how will I know I've repositioned the gridline plates correctly? If I don't put them in the right position/orientation...my composition will be off, correct?

  4. #4
    Barry S's Avatar
    Join Date
    Jan 2007
    Location
    DC Metro
    Shooter
    Large Format
    Posts
    1,200
    Images
    31
    I've taken the cover off of two Rapid 100s and had no issues with tight screws--you may not have any trouble. I wouldn't use anything else other than a sharp screwdriver of the correct size. Push down hard as you unscrew. Maybe someone used a bit of loctite (glue) on your original camera's screws?

    In my case, the fix for the plates was fairly intuitive--just spend a bit of time looking at the assembly and the problem may be obvious. If you can get the cover off of your working camera, you'll have a comparison. I'd be happy to send you some detailed photos if you get stuck. The plates have one correct position, so there are no worries about misalignment--they'll either be working or they won't.

    Good luck!

  5. #5
    altair's Avatar
    Join Date
    Mar 2009
    Location
    Kuala Lumpur, Malaysia
    Shooter
    Multi Format
    Posts
    392
    Right, thank you very much Barry. I do hope it's as straightforward as you make it sound like. If I become hopelessly stuck, I'll PM you for the photos.

    I've just come back from ACE hardware store & with me I have a slotted screwdriver that I hope is thin & torque-y enough to take those pesky screws off. I'll follow the instructions written by Al Thompson here: http://medfmt.8k.com/mf/infinity.html (about a third of the way down the page).

    Would you say the instructions given by Mr. Thompson are correct?



 

APUG PARTNERS EQUALLY FUNDING OUR COMMUNITY:



Contact Us  |  Support Us!  |  Advertise  |  Site Terms  |  Archive  —   Search  |  Mobile Device Access  |  RSS  |  Facebook  |  Linkedin