Switch to English Language Passer en langue française Omschakelen naar Nederlandse Taal Wechseln Sie zu deutschen Sprache Passa alla lingua italiana
Members: 70,291   Posts: 1,535,418   Online: 777
      
Results 1 to 8 of 8
  1. #1

    Join Date
    Sep 2011
    Location
    Chattanooga TN
    Shooter
    35mm
    Posts
    498
    Images
    11

    Bronica S - flash issue

    I recently acquired a Bronica S in pretty good shape. I'm not sure it has been used much; it winds properly, so after 52 years or so, the gears still seem to be OK.

    Apart from the fact that some of the really slow shutter speeds sometimes stall (a problem getting better with use), the main issue I have with the camera is that it won't work with a flash. I put the shutter at "X", push the shutter with the flash plugged in, and -- nothing. No flash.

    I suppose it could be anything - broken internal wire, dirty contacts etc. I just wondered if There were any common flash related issues with this model.

    The camera really is quite the beast, and I'm looking forward to taking it for a spin. I am sure it was quite the bees knees in its day. Tripping the shutter is rather amusing though; it's pretty loud and I am sure would be banned from many a church wedding nowadays.

  2. #2

    Join Date
    May 2007
    Location
    central anatolia, Turkey
    Shooter
    Medium Format
    Posts
    412
    Images
    16
    i assume you're turning the speed dail to X...

    sincerely, best of luck as i have been a satisfied user for 10 years.

  3. #3

    Join Date
    Sep 2011
    Location
    Chattanooga TN
    Shooter
    35mm
    Posts
    498
    Images
    11
    Yes, speed dial to X - must be a broken connection inside. The sync speed is only 1/50 anyway, so probably not much use for fill flash outdoors; and I can use hot lights inside; but it is a shame.

    I'm glad to hear from a satisfied user - I was a bit nervous to acquire it, having hear about problems with gears on this model - but it seems otherwise in flawless working condition.

  4. #4

    Join Date
    Nov 2010
    Location
    Charlotte, North Carolina, USA
    Shooter
    Medium Format
    Posts
    79
    Quote Originally Posted by newcan1 View Post
    Yes, speed dial to X - must be a broken connection inside. The sync speed is only 1/50 anyway, so probably not much use for fill flash outdoors; and I can use hot lights inside; but it is a shame.

    I'm glad to hear from a satisfied user - I was a bit nervous to acquire it, having hear about problems with gears on this model - but it seems otherwise in flawless working condition.
    I assume this goes without saying, but did you test the same setup of cable + flash on a camera with a known working PC port, immediately before trying it on the Bronica? (Just to isolate variables for sure.) I have an old S2 (non-A) which when wired up with a nodescript Kalt PC cable and a 1980s Canon flash, does flash. I've not tested this with film yet (to ensure the timing is right etc.) as I've only recently obtained the cable. (I'm an available light guy.)
    --Dave

  5. #5

    Join Date
    Sep 2011
    Location
    Chattanooga TN
    Shooter
    35mm
    Posts
    498
    Images
    11
    Yes, I have used the same flash and cable with one of my Nikon 35mm cameras and it works. I'm guessing that maybe the wire to the connector in the camera may have broken. It's probably not worth getting it fixed, but it is a shame, because the camera is otherwise in really good condition.

  6. #6

    Join Date
    May 2007
    Location
    central anatolia, Turkey
    Shooter
    Medium Format
    Posts
    412
    Images
    16
    you're in the states so finding a good technician for the wiring shouldn't be difficult. Mr Frank Marshman, İ've heard, is the best bronica repair man over there. the S and the EC are the only nikkor accepting bodies that have mirror lockup which makes them so attractive to tripod users. for flash work i imagine any of the S series would do. good luck.

  7. #7

    Join Date
    Apr 2004
    Location
    Montgomery, Il/USA
    Shooter
    Multi Format
    Posts
    5,042
    It doesn't have to be a broken wire. a bit of tarnish on the sync contacts is more likely.
    Heavily sedated for your protection.

  8. #8

    Join Date
    Sep 2011
    Location
    Chattanooga TN
    Shooter
    35mm
    Posts
    498
    Images
    11
    I hope you are right John! That would give me hop that if I keep playing with it, maybe it will come right.

    It seems to have been so well cared for, given its overall condition, that this is a distinct possibility. Heck, it's only a couple of years younger than me, and I wish I myself felt how it looks!



 

APUG PARTNERS EQUALLY FUNDING OUR COMMUNITY:



Contact Us  |  Support Us!  |  Advertise  |  Site Terms  |  Archive  —   Search  |  Mobile Device Access  |  RSS  |  Facebook  |  Linkedin