Switch to English Language Passer en langue française Omschakelen naar Nederlandse Taal Wechseln Sie zu deutschen Sprache Passa alla lingua italiana
Members: 70,273   Posts: 1,534,567   Online: 1028
      
Results 1 to 4 of 4
  1. #1

    Join Date
    Jul 2012
    Location
    Upstate NY
    Shooter
    Medium Format
    Posts
    5

    Bronica SQ-A 120 Back problems

    I'm not positive as to why this could be happening but I am unable to switch out the back that is on my camera right now and put another one on. There is film loaded into it, the slide is in, the multiple exposure lever is off, the mirror lock up lever is in the N position...is there something else that could be preventing me from taking it off?

  2. #2

    Join Date
    Dec 2009
    Shooter
    35mm
    Posts
    269
    I haven't had this problem with mine. The safety mech, however, is operated by inserting and removing the darkslide. I suspect it is a simple mechanical latch. Do you have another back to examine? That would at least let you see how it operates, and possibly identify the fault. Alex

  3. #3

    Join Date
    Dec 2009
    Shooter
    35mm
    Posts
    269
    Another thought. Is the darkslide the right way up? The grey ones have a circular mark on the end. That should be at the top of the slot for it to work properly. Alex

  4. #4

    Join Date
    Jul 2012
    Location
    Upstate NY
    Shooter
    Medium Format
    Posts
    5
    Jeez now I feel like an idiot haha the slide was in the wrong way....thanks Alex!



 

APUG PARTNERS EQUALLY FUNDING OUR COMMUNITY:



Contact Us  |  Support Us!  |  Advertise  |  Site Terms  |  Archive  —   Search  |  Mobile Device Access  |  RSS  |  Facebook  |  Linkedin