Switch to English Language Passer en langue française Omschakelen naar Nederlandse Taal Wechseln Sie zu deutschen Sprache Passa alla lingua italiana
Members: 71,957   Posts: 1,586,089   Online: 1016
      
Results 1 to 3 of 3

Thread: 50mm sl66

  1. #1
    k.hendrik's Avatar
    Join Date
    May 2008
    Location
    The Netherlands
    Shooter
    Multi Format
    Posts
    313
    Images
    80

    50mm sl66

    Hi, bought a 'Distagon 50 f4 sl66' looking like new; but on my sl66se it doesn't function the way I expected. Speed:yes but no 'f' in my finder !? Is there a way to modify this lens ? or grab a lightmeter out of the bag?
    Thanks.

  2. #2

    Join Date
    Nov 2002
    Location
    Melbourne, Australia
    Shooter
    Medium Format
    Posts
    1,013
    It seems to me that you have an older lens without the "E-ring" that couples the aperture ring to the meter. If you look at your 80mm lens that works with the meter you will notice a ring fitted in which there is a screw that moves the meter coupling prong when the lens is mounted. Turning the aperture ring then moves the camera's metering prong. E-rings can be expensive, but for lenses with short aperture rings (80/2.8, your lens, 40/4 and maybe others) a small rectangle of rubber or metal or something else can be glued to the lens's aperture ring. This post might help:

    http://www.apug.org/forums/forum51/9...66-e-ring.html

    In that post, the pencil mark shows where the prong needs to be when the lens is mounted and its aperture ring is set to fully open (f4 in the case of your 50/4).

  3. #3
    k.hendrik's Avatar
    Join Date
    May 2008
    Location
    The Netherlands
    Shooter
    Multi Format
    Posts
    313
    Images
    80
    john_s send PM



 

APUG PARTNERS EQUALLY FUNDING OUR COMMUNITY:



Contact Us  |  Support Us!  |  Advertise  |  Site Terms  |  Archive  —   Search  |  Mobile Device Access  |  RSS  |  Facebook  |  Linkedin