Switch to English Language Passer en langue française Omschakelen naar Nederlandse Taal Wechseln Sie zu deutschen Sprache Passa alla lingua italiana
Members: 71,834   Posts: 1,582,394   Online: 905
      
Results 1 to 3 of 3
  1. #1
    Daniel_OB's Avatar
    Join Date
    Jun 2006
    Location
    Mississauga, Canada
    Shooter
    Multi Format
    Posts
    420

    mamiya RZ67 ProII problem

    About mamiya RZ67 ProII.
    Just shot 3 rools 120 with some changing lenses on the way. At the end of third roll I spoted my blind is in its blind slot and camera should not shoot until the blind is out. Fortunately 2 rolls are fine.
    Does anyone have any idea how it happened. Any similar experience.

    www.Leica-R.com

  2. #2

    Join Date
    Jan 2006
    Location
    U.K.
    Shooter
    Multi Format
    Posts
    1,355
    I have the same camera and the shutter will not work if the dark slide is in position. It sounds very strange - ... are you certain the dark slide wasn't in the 'storage' slide (at the back), rather than between the film + camera body? The shutter will work if it's in that position, and there would be no problem if so...Otherwise, sorry, I don't know what to suggest, I've never experienced that....
    Cate

  3. #3

    Join Date
    Dec 2004
    Location
    Milwaukee, Wi
    Shooter
    35mm
    Posts
    3,242
    I have experienced that with my RZ67.
    Claire (Ms Anne Thrope is in the darkroom)



 

APUG PARTNERS EQUALLY FUNDING OUR COMMUNITY:



Contact Us  |  Support Us!  |  Advertise  |  Site Terms  |  Archive  —   Search  |  Mobile Device Access  |  RSS  |  Facebook  |  Linkedin