Switch to English Language Passer en langue française Omschakelen naar Nederlandse Taal Wechseln Sie zu deutschen Sprache Passa alla lingua italiana
Members: 70,593   Posts: 1,546,087   Online: 877
      
Results 1 to 5 of 5
  1. #1

    Join Date
    May 2008
    Shooter
    35mm
    Posts
    4

    Mamiya C330 help!

    I just purchased a Mamiya C330, a camera that I've always wanted to own and use, and much to my dismay, there seems to be a problem. The film winding lever doesn't turn the film spool, it just cranks freely. Is there something I'm supposed to do to get it to work? If it needs repair, is it an expensive one?

  2. #2
    MattKing's Avatar
    Join Date
    Apr 2005
    Location
    Delta, British Columbia, Canada
    Shooter
    Multi Format
    Posts
    12,405
    Images
    60
    Do you have it set for multiple exposure? The switch is on the right side, near the front, quite close to the top shutter release.

    Matt

  3. #3

    Join Date
    May 2008
    Shooter
    35mm
    Posts
    4
    Quote Originally Posted by MattKing View Post
    Do you have it set for multiple exposure? The switch is on the right side, near the front, quite close to the top shutter release.

    Matt
    I've tried it on both settings, single and multiple, the crank doesn't feel like its engaging anything.

    Stefan.

  4. #4

    Join Date
    Apr 2007
    Location
    Ontario
    Shooter
    Multi Format
    Posts
    775
    Images
    28
    The switch could be broken and just locked on multiple exposure. I once had this problem a long time ago. If you could take off the plate and try to engage it from the inside and leave it at single exposure, you may save a lot of time and agony. Just don't mess anything else up. it seems like it should be easy to repair for a film camera tech and not cost much more than $50. I'm sorry to hear about your luck. You should contact the seller and ask them what the crap they were thinking when they decided to sell you a non-functioning camera.

  5. #5
    thebanana's Avatar
    Join Date
    Nov 2004
    Location
    Manitoba, Canada
    Shooter
    Medium Format
    Posts
    2,651
    Images
    121
    I had a similar problem with my Mamiya 1000s. It was a $90 fix, but worth it.
    "While you're out there smashing the state, don't forget to keep a smile on your lips and a song in your heart!"



 

APUG PARTNERS EQUALLY FUNDING OUR COMMUNITY:



Contact Us  |  Support Us!  |  Advertise  |  Site Terms  |  Archive  —   Search  |  Mobile Device Access  |  RSS  |  Facebook  |  Linkedin