Switch to English Language Passer en langue française Omschakelen naar Nederlandse Taal Wechseln Sie zu deutschen Sprache Passa alla lingua italiana
Members: 70,225   Posts: 1,532,662   Online: 838
      
Results 1 to 7 of 7
  1. #1

    Join Date
    May 2008
    Shooter
    Medium Format
    Posts
    5

    Mamiya C330 Flash Problems

    I have a C330 the shutter was sticking so I have had it apart cleaning it that part seems ok now. Seems to be ok with no flash.
    I tried some flash shots inside I used a 40d hooked to a tv to get the the flash, iso, ap., and shutter speed set. That looked like I wanted so I set the C330 the same iso, ap, shutter, distance were all the same. Developed the hp5 in xtol and the film was blank. The numbers and lettering on the edges were there and two exposers had a little bit of image but not much.
    I did notice afterwards the flash sync lever was about half way between the x and m.
    Would that be enough to do it? I thought having the settings the same from both the 40d and the c330 it would be close.

    Thanks

  2. #2

    Join Date
    Feb 2008
    Location
    Winnipeg, Canada
    Shooter
    Multi Format
    Posts
    1,301
    Om M sync the lead time on the flash is somewhere around 20 milliseconds, so your flash would have fired before the leaf shutter was even open.

  3. #3
    Bryce Parker's Avatar
    Join Date
    Sep 2006
    Shooter
    Medium Format
    Posts
    30
    All 3 of my Mamiya's lenses had that switch epoxied in the "X" position 4 their previous owners for some reason...

  4. #4
    benjiboy's Avatar
    Join Date
    Apr 2005
    Location
    U.K.
    Shooter
    Multi Format
    Posts
    6,743
    Make sure the flash sync. lever is on X, and try again, if it was between X and M as a previous poster said it might have given the time delay for flash bulbs, not electronic flash, and the shutter would be closed as the flash fired.
    Bryce Parker- The previous owner was probably a wedding photographer, many of them in the old days used to do this, so they didn't f**k up their clients wedding shots by catching the lever on something and knocking it off X sync.
    Last edited by benjiboy; 08-16-2008 at 04:53 PM. Click to view previous post history.
    Ben

  5. #5

    Join Date
    Oct 2004
    Shooter
    Multi Format
    Posts
    726
    Make sure that you have the flash set to X. On my wife's 330 having it mis set can also make the shutter seem to jam and might have caused your original problem.

    David.

  6. #6
    raucousimages's Avatar
    Join Date
    May 2003
    Location
    Salt Lake
    Shooter
    Large Format
    Posts
    825
    X is for electronic flash.
    M is for flash bulbs.
    On M the flash fires prior to the shutter opening so when it if fully open the bulb is burning at it's brightest point.
    DIGITAL IS FOR THOSE AFRAID OF THE DARK.

  7. #7

    Join Date
    May 2008
    Shooter
    Medium Format
    Posts
    5
    Thanks, for the replies.



 

APUG PARTNERS EQUALLY FUNDING OUR COMMUNITY:



Contact Us  |  Support Us!  |  Advertise  |  Site Terms  |  Archive  —   Search  |  Mobile Device Access  |  RSS  |  Facebook  |  Linkedin