Switch to English Language Passer en langue française Omschakelen naar Nederlandse Taal Wechseln Sie zu deutschen Sprache Passa alla lingua italiana
Members: 69,983   Posts: 1,523,899   Online: 1077
      
Results 1 to 6 of 6
  1. #1
    Gerry M's Avatar
    Join Date
    Nov 2005
    Location
    Oregon
    Shooter
    Multi Format
    Posts
    768
    Images
    135

    Bronica film insert disassembly

    Has anyone here successfully disassembled a 120 film insert for a Bronica SQ-Ai? If not, any idea where to find the info? Tried a search and came up blank. My film counter sticks on 1, even tho the film advances without indexing, until the complete roll is cranked thru. The shutter is in-op during this. Any help or info is appreciated.
    Gerry

  2. #2
    delphine's Avatar
    Join Date
    Jun 2007
    Location
    London (UK)
    Shooter
    Medium Format
    Posts
    628
    Images
    13
    Gerry,

    It looks to me like you are superposing the exposures. Check the position of the superposition lever at the left of your camera body. It should be pointing upwards. If it not, then reposition it, and you'll find that you can then run though the rest of the index numbers.

    I don't have the SQ-AI myself but the ETRSi. The multi-exposure lever is the same on both bodies though.
    If my advice does not address the issue, then somebody else can chim in as there are quite a few SQ-AI users.

    Good luck.

    Dee

  3. #3

    Join Date
    Apr 2004
    Location
    Vancouver, BC
    Shooter
    Large Format
    Posts
    142
    I've taken a few apart, so I'll have a go at this...

    To get to the mechanism, remove the winding knob and the screws under the leatherette, and take off the cover. Note that the screw fixing the winding knob has a left-hand thread - that is, you turn it clockwise to loosen.

    Once the cover is off, you'll see the plastic counter wheel with the frame numbers - it should turn freely and spring back snappily against its stop. I think your problem, though, is the set of slotted disks underneath the counter wheel. These disks are driven by a gear train from the roller next to the film take-off spool (the top roller by the frame counter), and when a frame's worth of film has rolled past, a spring-loaded lever snaps into the next slot on the disk and prevents further winding. When you fire the camera, the body pushes a pin on the back which releases the lever from the slot and allows the next frame to wind on. Something in that mechanism train is probably not letting the lever to fall into the slot, therefore allowing the winding to continue uninterrupted right through the roll.

    That's a simplified description of what's going on in there, so you could try to find the problem by removing the cover, mounting the back with a scrap roll of film onto the camera and watching the operation. If all else fails, the cheapest thing is probably to buy another used insert...

    Jim

  4. #4
    PhotoJim's Avatar
    Join Date
    Oct 2005
    Location
    Regina, SK, CA
    Shooter
    Multi Format
    Posts
    2,221
    You can get BGN-graded SQ-series film backs from KEH for around $50 each, which will work well. If the repair looks complex, consider simply getting another back. (You can also buy the inserts and use the back you already have.)
    Jim MacKenzie - Regina, Saskatchewan, Canada

    A bunch of Nikons; Feds, Zorkis and a Kiev; Pentax 67-II (inherited from my deceased father-in-law); Bronica SQ-A; and a nice Shen Hao 4x5 field camera with 3 decent lenses that needs to be taken outside more. Oh, and as of mid-2012, one of those bodies we don't talk about here.

    Favourite film: do I need to pick only one?

  5. #5
    Gerry M's Avatar
    Join Date
    Nov 2005
    Location
    Oregon
    Shooter
    Multi Format
    Posts
    768
    Images
    135
    Thanks to all for the response.

    Jim Landecker; You are right. It is something in the linkage to the notched indexing discs, or the discs themselves.. It is simple to disassemble, but from there I can't seem to find what is the source of the problem. It almost seems like the discs are out of synch. Everything else seems to be working properly. This insert appears to have seen very little use.
    Gerry

  6. #6
    Gerry M's Avatar
    Join Date
    Nov 2005
    Location
    Oregon
    Shooter
    Multi Format
    Posts
    768
    Images
    135
    PhotoJim,
    I took your advice and got a BIN insert from Shutterblade, just in case. For $29+shp, I kind of hedged my bet. Thanks for the input.
    Gerry



 

APUG PARTNERS EQUALLY FUNDING OUR COMMUNITY:



Contact Us  |  Support Us!  |  Advertise  |  Site Terms  |  Archive  —   Search  |  Mobile Device Access  |  RSS  |  Facebook  |  Linkedin