Switch to English Language Passer en langue française Omschakelen naar Nederlandse Taal Wechseln Sie zu deutschen Sprache Passa alla lingua italiana
Members: 71,821   Posts: 1,581,780   Online: 1029
      
Page 3 of 3 FirstFirst 123
Results 21 to 23 of 23
  1. #21

    Join Date
    Jan 2009
    Location
    Vienna, AT
    Shooter
    Medium Format
    Posts
    38
    Corto, did you sort out your issue? I'm having a similar problem with my new RZ67 Pro and 65mm RB lens. I'm attaching the lens when mirror is in down position and the lens shutter is cocked, of course. With RM lever at M position, the camera will fire with lens removed. With lens installed, it will just click, both emergency shutter and with battery installed (in the latter case it's not giving me the orange or red light). I suppose something is wrong with the lens, or it won't fire on this particular body. Maybe the shutter cocking pins don't catch. Note I don't have a T switch on my lens. BTW, to know if the mirror-up socket is in the *out* position?

    Note: yesterday I was able to fire the first shot if I release the lens shutter, then cock the lens when mounted onto the body and then press release button. The problem was only with successive shots. It looks like I can't fire a single shot successfully anymore. The camera just clicks. Besides, sometimes it would jam after the click and to workaround this I have to remove the lens. At the moment I remove the lens the mirror jumps up. This all seems to me that the problem is in the lens. Maybe it's stuck in the mirror up mode?
    Last edited by marduk; 03-02-2011 at 02:09 PM. Click to view previous post history.

  2. #22

    Join Date
    Jun 2008
    Shooter
    Medium Format
    Posts
    10
    Maybe the connection to a cable release on the lens isn't fully retracted. I know I had trouble with that once and it wasn't the first thing I thought of.

  3. #23

    Join Date
    Jan 2009
    Location
    Vienna, AT
    Shooter
    Medium Format
    Posts
    38
    Well, I guess the shutter cocking pins are too tight on my lens. I saw a youtube video where a man cocked and released shutter on the lens removed from the camera body easily, with his fingertips.
    On my lens, the pins turn really right. Besides, the fact that mirror sometimes triggers but gets stuck suggests there's a problem with engaging lens shutter. I will go to a local shop during the weekend that has other RB lenses and RB body to confirm my guess.

Page 3 of 3 FirstFirst 123


 

APUG PARTNERS EQUALLY FUNDING OUR COMMUNITY:



Contact Us  |  Support Us!  |  Advertise  |  Site Terms  |  Archive  —   Search  |  Mobile Device Access  |  RSS  |  Facebook  |  Linkedin