Switch to English Language Passer en langue française Omschakelen naar Nederlandse Taal Wechseln Sie zu deutschen Sprache Passa alla lingua italiana
Members: 69,766   Posts: 1,516,419   Online: 975
      
Results 1 to 4 of 4
  1. #1

    Join Date
    May 2006
    Shooter
    35mm
    Posts
    509

    Bronica AEII issues

    no matter what I set the aperture or ISO for, the meter reads 2 for 1/2 a second....any chance this is a battery issue? If not, other suggestions?

  2. #2

    Join Date
    Mar 2008
    Shooter
    Medium Format
    Posts
    72
    They are very battery dependent. Even if the battery check light comes on it may not work. Try a new battery. Also clean the contacts on the lens/body/finder.
    "If you look at a thing nine hundred and ninety-nine times, you are perfectly safe; if you look at it the thousandth time, you are in frightful danger of seeing it for the first time." G.K.Chesterton

  3. #3

    Join Date
    May 2006
    Shooter
    35mm
    Posts
    509
    Quote Originally Posted by jime11 View Post
    They are very battery dependent. Even if the battery check light comes on it may not work. Try a new battery. Also clean the contacts on the lens/body/finder.
    do you have suggestions for a particular brand of battery? I realize silver oxide ones are the "best" according to Bronica, but are they worth the cost over alkaline?

  4. #4
    benjiboy's Avatar
    Join Date
    Apr 2005
    Location
    U.K.
    Shooter
    Multi Format
    Posts
    6,639
    Yes they are, and the Lithium PX28L is even better.
    Ben



 

APUG PARTNERS EQUALLY FUNDING OUR COMMUNITY:



Contact Us  |  Support Us!  |  Advertise  |  Site Terms  |  Archive  —   Search  |  Mobile Device Access  |  RSS  |  Facebook  |  Linkedin