Switch to English Language Passer en langue française Omschakelen naar Nederlandse Taal Wechseln Sie zu deutschen Sprache Passa alla lingua italiana
Members: 70,545   Posts: 1,544,463   Online: 1041
      
Results 1 to 4 of 4
  1. #1

    Join Date
    Nov 2010
    Location
    Tokyo
    Shooter
    Multi Format
    Posts
    344

    Bronica SQ-A finder going bad

    The AE finder on my SQ-A has started to give inaccurate readings, leading to photos that are 1-2 stops underexposed. It was working fine as recently as this past summer. I have cleaned all the contact points on the finder and body and lenses, and confirmed that it does this with multiple lenses. Is there anything else I can do myself before giving up and shopping for a new finder or sending it in for repairs? What causes these meters to go bad?
    Pentax 67ii, Fuji GF670, Mamiya 6, Pentax 645N
    Chemical Cameras
    My Galleries

  2. #2
    CGW
    CGW is offline

    Join Date
    Apr 2010
    Shooter
    Medium Format
    Posts
    2,797
    No clues on causation. I know competent repair options are scarce for Bronica but Koh's can usually fix sick SQ gear:

    http://kohscamera.com/

    Otherwise, you may be ahead shopping for a new AE finder. Sorry

  3. #3
    NJS
    NJS is offline
    NJS's Avatar
    Join Date
    Nov 2009
    Shooter
    Medium Format
    Posts
    125
    have you checked if the problem is not actually with the back instead of the prism?

  4. #4

    Join Date
    Nov 2010
    Location
    Tokyo
    Shooter
    Multi Format
    Posts
    344
    Oh, I forgot to mention that. I have 3 backs and I get identical readings with all three...
    I've also checked the battery.
    Pentax 67ii, Fuji GF670, Mamiya 6, Pentax 645N
    Chemical Cameras
    My Galleries



 

APUG PARTNERS EQUALLY FUNDING OUR COMMUNITY:



Contact Us  |  Support Us!  |  Advertise  |  Site Terms  |  Archive  —   Search  |  Mobile Device Access  |  RSS  |  Facebook  |  Linkedin