Switch to English Language Passer en langue française Omschakelen naar Nederlandse Taal Wechseln Sie zu deutschen Sprache Passa alla lingua italiana
Members: 70,702   Posts: 1,548,436   Online: 989
      
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: RZ67 dead

  1. #1

    Join Date
    Nov 2011
    Location
    VA, USA
    Shooter
    35mm
    Posts
    10

    RZ67 dead

    Hello, all. I'm a new RZ67 Pro II user; I just picked up this outfit used is week. My familiarity is with 35mm SLRs only.

    When I say my RZ67 is dead, I mean that there are no lights, sounds, nothing. I currently have a Polaroid back with film on it, but previously had the 6x6 back on it (no film). I have the AE Prism Finder (I?) on it, and it appears to be seated correctly. I replaced the silver oxide battery in it just this afternoon...

    Shouldn't there be some LED that comes on for something? Shouldn't I see some status in the prism finder? I can release the shutter (dark slide in) and it all appears to be working mechanically. Setting the side shutter to AEF (for the prism) seems to do nothing. Both using he AEF/top dial and the side dial to set the shutter speed sound the same. I'm pretty sure all it's doing is the ~1/400 mechanical shutter speed.

    What's wrong with my camera? Is there something I'm forgetting to turn on? Is it really dead? If so, how should it be repaired?

  2. #2
    Sirius Glass's Avatar
    Join Date
    Jan 2007
    Location
    Southern California
    Shooter
    Multi Format
    Posts
    13,158
    I am not familiar with the RZ67 Pro II, however I would suggest that you check the battery and the battery terminals in the camera first. Is the battery inserted correctly? Try replacing the battery.

    If you need the instruction manual, you can find them => http://www.butkus.org/chinon/ If you find the download useful, please send in $3 to support that free website.

    More knowledgeable RZ67 users will answer your questions soon.

    Welcome to APUG

    Steve
    Warning!! Handling a Hasselblad can be harmful to your financial well being!

    Nothing beats a great piece of glass!

    I leave the digital work for the urologists and proctologists.

  3. #3

    Join Date
    Nov 2011
    Location
    VA, USA
    Shooter
    35mm
    Posts
    10
    Thanks for the reply and the welcome!

    I did check correct insertion of the battery and inspected the terminals but you know what? I'll do it again.

    I already have the manuals for the RZ67 Pro II and for the AE Prism Finder, but thanks for that tip, too.

  4. #4

    Join Date
    Apr 2010
    Location
    Guelph, Ontario
    Shooter
    Medium Format
    Posts
    298
    There is a ring around the shutter release button with a white dot on it. Make sure the white dot is lined up with the white dot on the body. Orange dot is mechanical 1/400th, and red dot is shutter locked.

  5. #5

    Join Date
    Apr 2010
    Location
    Guelph, Ontario
    Shooter
    Medium Format
    Posts
    298
    Also, if you have the AE prism I, you can only use autoexposure with the prism dial. All the manual speeds are off if you try to set them using the prism.

  6. #6

    Join Date
    Nov 2011
    Location
    VA, USA
    Shooter
    35mm
    Posts
    10
    Whoa!

    The shutter release was on the orange dot. I moved it to the white dot in the middle, and we have beeps and LEDs (blinking red LED under the battery icon? Oh wait, now it's not on), and I saw some numbers on the left side of viewfinder a second ago. I can decode all of this with the manual.

    Clearly, I need to learn more about the camera but this is a breakthrough!

    Thank you, thank you, thank you!


  7. #7

    Join Date
    Nov 2011
    Location
    VA, USA
    Shooter
    35mm
    Posts
    10
    (It says only, "RZ67 AE PRISM FINDER" on it, and there are two dials on the top of it.)

    You mean just the "A" setting on the prism dial? I'm not sure I follow your comment.

  8. #8

    Join Date
    Apr 2010
    Location
    Guelph, Ontario
    Shooter
    Medium Format
    Posts
    298
    top dials is the new prism model, works with RZII. You're good to go, functionality should be perfect. Half-press the shutter to get a meter reading, full-press to use whatever shutter speed you've selected on the prism (or AE). AEL is super handy - I usually leave it there so you can do the old meter-recompose-shoot thing.

  9. #9

    Join Date
    Nov 2011
    Location
    VA, USA
    Shooter
    35mm
    Posts
    10
    I set the side to AEF, the top to A. The lens was set to f/2.8 indoors, lamp light. I pressed the shutter release all the way, and nothing happened. (Well, the camera beeped and flashed near the dark slide icon but I'm using the Polaroid back so it probably doesn't know it's out.) Anyway, I'm guessing it was just too dark and refused to release.

    I took off the prism and shot with the WL finder just now, with a manual shutter speed (metered at 1/4 second, shot 1/3). It fired as expected and gave expected results, too.

    I need to read up on this prism a little more.

    Thanks so much for your replies!

  10. #10
    L Gebhardt's Avatar
    Join Date
    Jun 2003
    Location
    NH - Live Free or Die
    Shooter
    Large Format
    Posts
    1,700
    Blog Entries
    1
    Images
    18
    I've never use the polaroid back, but the regular backs have interlocks for the darkslide, and I think for when the film isn't loaded. So check that the back is ready to take a shot.

Page 1 of 2 12 LastLast


 

APUG PARTNERS EQUALLY FUNDING OUR COMMUNITY:



Contact Us  |  Support Us!  |  Advertise  |  Site Terms  |  Archive  —   Search  |  Mobile Device Access  |  RSS  |  Facebook  |  Linkedin