Switch to English Language Passer en langue française Omschakelen naar Nederlandse Taal Wechseln Sie zu deutschen Sprache Passa alla lingua italiana
Members: 70,499   Posts: 1,543,219   Online: 1061
      
Results 1 to 2 of 2
  1. #1
    ParkerSmithPhoto's Avatar
    Join Date
    Jan 2010
    Location
    Atlanta, GA
    Shooter
    Medium Format
    Posts
    811
    Images
    6

    Bronica Shutter Problem

    My Bronica SQ-A seems to have a bit of a problem with shutter speed consistency. Taking off the film back and firing the shutter at random speeds, it's pretty obvious that every so often the shutter just does what it wants to, rather than what I ask it to. I noticed this today on a roll that I developed.

    Any advice? I know the shutter is in the lens, so I hope I'm not going to have to drop any serious cash to get this fixed.

    EDIT: It appears to be doing this with multiple lenses. And on both of my SQ bodies. Geez. I hope that leaving them unused for a while didn't hurt them. I did not close the shutters as is recommended.
    Parker Smith Photography, Inc.
    Atlanta, GA

    Commercial & Fine Art Photography
    Portrait Photography

  2. #2
    Sirius Glass's Avatar
    Join Date
    Jan 2007
    Location
    Southern California
    Shooter
    Multi Format
    Posts
    13,117
    I suggest that you get a CLA [clean, lub, adjust] done. By the way check out KEH in your neighborhood for the CLA www.keh.com
    KEH Repair
    4900 Highlands Parkway SE
    Smyrna, Ga 30082

    email:repairs@keh.com
    telephone Monday through Friday 8:30 am – 5:00 pm EST at (770) 333-4210

    Steve
    Warning!! Handling a Hasselblad can be harmful to your financial well being!

    Nothing beats a great piece of glass!

    I leave the digital work for the urologists and proctologists.



 

APUG PARTNERS EQUALLY FUNDING OUR COMMUNITY:



Contact Us  |  Support Us!  |  Advertise  |  Site Terms  |  Archive  —   Search  |  Mobile Device Access  |  RSS  |  Facebook  |  Linkedin