Switch to English Language Passer en langue française Omschakelen naar Nederlandse Taal Wechseln Sie zu deutschen Sprache Passa alla lingua italiana
Members: 70,337   Posts: 1,537,588   Online: 1138
      
Results 1 to 4 of 4
  1. #1

    Join Date
    Mar 2010
    Shooter
    35mm
    Posts
    10

    Contax TVS - Electronics issue?

    I have been using a (second hand) Contax TVS camera for about a year now, but recently have had some strange problems with it and finally it looks like it might be pooched.

    Sometimes, especially when using the flash, the first shot taken after being turned on would cause the shutter open but not close. If I couldn't hear the shutter close, I would turn the camera off and turn it back on and then it would make a funny clicking sound -- I'm assuming it was something to do with shutter, as the camera would expect it to be closed when it turns on. The next shot I would take, however, would be fine. After a while of this, it now refuses to turn on. When the power/zoom lever is moved to ON nothing appears in the LCD screen (the second frame counter screen is working) and the shutter with not trigger. I've put a fresh battery in, but it was no use. I was still able to rewind the film back into the canister.

    Has anyone else experienced this type of problem with the TVS? Any insight would be helpful. I love using this camera, and would probably pay to have it repaired, so if anyone could recommended a good place to get a Contax repaired that would also be helpful (I'm located in Toronto.)

    Thanks,

    Aaron

  2. #2

    Join Date
    Sep 2012
    Shooter
    35mm
    Posts
    1
    Hello, I was doing an internet search for the problem my Contax TVS developed, and I found your problem to be very similar to mine. Actually I've narrowd down to an autofocus issue, whenever the AF kicks in the camera turns off, and only by retracting the lens to the OFF position the shutter is activated and the film advances. At first it was more frequent with higher focal lenght (aprox. above 40mm) but now it happens even with the lens at its widest.
    Have you found a solution yet? I live in Mexico, and the chances of getting it repaired here are very slim... and with the money it would cost me to send it to the US I can almost buy another used one. So, I really don't know what to do, I think it's an excelent camera to let die, yet I am somehow limited by budget.
    Thank you very much for your time (:

  3. #3

    Join Date
    Jun 2011
    Shooter
    35mm RF
    Posts
    60
    ive been using the tvs iii for a while with no issues. my t2 once fired with the flash and froze but that never happened again.

  4. #4

    Join Date
    Sep 2004
    Location
    New Jersey (again)
    Shooter
    35mm RF
    Posts
    1,976
    My camera does the same thing. When turned on, it emits a rapid series of clicks. Haven't investigated further. I'm a bit upset, as this is otherwise a nice camera.

    Just another reason to avoid electronics when it comes to camera.



 

APUG PARTNERS EQUALLY FUNDING OUR COMMUNITY:



Contact Us  |  Support Us!  |  Advertise  |  Site Terms  |  Archive  —   Search  |  Mobile Device Access  |  RSS  |  Facebook  |  Linkedin