Switch to English Language Passer en langue française Omschakelen naar Nederlandse Taal Wechseln Sie zu deutschen Sprache Passa alla lingua italiana
Members: 70,218   Posts: 1,532,220   Online: 856
      
Results 1 to 4 of 4
  1. #1
    Halka's Avatar
    Join Date
    Oct 2012
    Location
    SVK, EU
    Shooter
    35mm
    Posts
    35

    Nikon FA shutter/mirror sound

    I've just received my Nikon FA. While playing around with it, I've noticed it has two distinct shutter/mirror sounds, depending on which mode is it set to. If I trip the shutter while in P(ro) or S mode, it responds with a satisfying *clak*; but when firing in M or A mode, there is something else; like if my neighbor dropped a box of cutlery to the floor. First I thought it was the sound of a sub-mirror hitting the main one, but then I realized that FA only has a single mirror. Otherwise the camera works perfectly, shutter speeds sound about right, but I haven't finished my first roll of film in it yet.

    Has anyone else had a similar experience?

  2. #2

    Join Date
    Jul 2012
    Shooter
    35mm
    Posts
    65
    If you mean, like it's got a loose spring, yes. I sold mine because of that sound. Worked perfectly though. My other Nikons have a very solid, reassuring and satisfying shutter sound.

  3. #3

    Join Date
    May 2008
    Location
    Knoxville, TN
    Shooter
    Medium Format
    Posts
    16
    I have three FAs that I got as part of a job lot of gear and I think they are good little cameras. The shutter sound though, particularly when compared to other Nikons, is distinctly odd. Mike's description is pretty accurate

  4. #4
    Halka's Avatar
    Join Date
    Oct 2012
    Location
    SVK, EU
    Shooter
    35mm
    Posts
    35
    Thanks guys, seems like everything is in order then.



 

APUG PARTNERS EQUALLY FUNDING OUR COMMUNITY:



Contact Us  |  Support Us!  |  Advertise  |  Site Terms  |  Archive  —   Search  |  Mobile Device Access  |  RSS  |  Facebook  |  Linkedin