Switch to English Language Passer en langue française Omschakelen naar Nederlandse Taal Wechseln Sie zu deutschen Sprache Passa alla lingua italiana
Members: 70,690   Posts: 1,548,845   Online: 958
      
Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12

Thread: Olympus OM-2n

  1. #11

    Join Date
    Feb 2009
    Location
    Mission Viejo, California
    Shooter
    127 Format
    Posts
    1,465
    I also recently got an EXC+++ / near mint OM-1 in black that has a broken plastic battery connection screw so the meter doesn't work.

    I think it happened early in the camera's life so it spent many years unused on a shelf somewhere. The advance lever stiffened up to the point where you have to force it closed.

    I removed the top to take out the melted foam and lubricated the film advance shaft and it 'sprang' back to life.

    The camera works great now. (well, except the meter still doesn't work due to the plastic screw and of course it has a touch of the prism grunge...)
    - Bill Lynch

  2. #12

    Join Date
    Apr 2004
    Location
    Montgomery, Il/USA
    Shooter
    Multi Format
    Posts
    5,115
    The return spring attaches to the advance lever under the screw holding the lever on.
    If the camera has been "serviced" in the past the spring may be trapped under the lever. It may also be broken or just be old lube.
    By removing the screw the shaft that the lever pivots on is plainly visible and an itsy-bitsy teensie weensie(IE, head of pin size) drop of oil should cure it.
    Heavily sedated for your protection.

Page 2 of 2 FirstFirst 12


 

APUG PARTNERS EQUALLY FUNDING OUR COMMUNITY:



Contact Us  |  Support Us!  |  Advertise  |  Site Terms  |  Archive  —   Search  |  Mobile Device Access  |  RSS  |  Facebook  |  Linkedin