Switch to English Language Passer en langue française Omschakelen naar Nederlandse Taal Wechseln Sie zu deutschen Sprache Passa alla lingua italiana
Members: 70,206   Posts: 1,531,864   Online: 1003
      
Results 1 to 4 of 4
  1. #1

    Join Date
    Oct 2013
    Shooter
    35mm
    Posts
    99

    Nikon F4, Film loading/advance problem

    Dear All,
    My Nikon F4 recently had developed a strange fault. When trying to load film, upon first shot the film advances to the first frame and then the red led comes on. After waiting for a while pressing the shutter button again it moves the film as if trying to load it and then halts with a red led again. The batteries are fresh.
    Do you know why this has happened all of a sudden? Is it something that can be repaired by me? If not, is it worth repairing it, or buying another body?

    Many thanks in advance for your advice.

  2. #2
    John_Nikon_F's Avatar
    Join Date
    Apr 2008
    Location
    Duvall, WA, USA
    Shooter
    35mm
    Posts
    1,415
    Images
    2
    The R2 lever is in its normal position, right? If not, reset it and try again. If it is, then I'm guessing there's an issue with the sensor that tells the camera that your film is ready to be loaded. Unless the camera is really nice cosmetically, it's probably going to be a better idea to grab another body, then tear this one down for parts. An overhaul can run upwards of $300. Nice F4 bodies can be had for half that from time to time. My previous F4s was one that I bought for $143.50, plus shipping. Was almost mint, cosmetically. Even had the cap on the cable release socket and was a fairly late model, being in the 2516xxx serial range.

    -J
    APUG: F4, F3P, F2ASx2, F
    DPUG: D200
    Nikkors: 18-70/3.5-4.5G AF-S DX (f/D200), 24/2.8 AI, 35/135/3.5-4.5 AIS, 50/1.4 AI, 50/2 H, 85/1.8 K, 105/4 Micro AIS, 180/2.8 ED AIS, 300/4.5 ED AI

    My FB - My flickr stream
    My SmugMug

  3. #3
    Ricardo Miranda's Avatar
    Join Date
    Mar 2012
    Location
    London, UK
    Shooter
    35mm
    Posts
    573
    An overhaul can run upwards of $300.
    In the UK, it is only £100 for a CLA by a Nikon authorised repairer. Send it to: http://www.aztechservices.com
    My cameras:
    Fed 2
    Zenit 11, 12XP
    Nikon F4, F4S, F401S, F601, F801, F801S, F50, F55, F60, F65, F70, F75, F80, F90, F90X, EL2, FE, FM, FG, FG-20, EM

  4. #4

    Join Date
    Oct 2013
    Shooter
    35mm
    Posts
    99
    I had no response from them so far. Anyway, I have bought another one. I will find somebody to repair it though, no matter what.



 

APUG PARTNERS EQUALLY FUNDING OUR COMMUNITY:



Contact Us  |  Support Us!  |  Advertise  |  Site Terms  |  Archive  —   Search  |  Mobile Device Access  |  RSS  |  Facebook  |  Linkedin