Switch to English Language Passer en langue française Omschakelen naar Nederlandse Taal Wechseln Sie zu deutschen Sprache Passa alla lingua italiana
Members: 69,727   Posts: 1,515,151   Online: 1075
      
Page 1 of 2 12 LastLast
Results 1 to 10 of 12
  1. #1
    BruceN's Avatar
    Join Date
    Aug 2004
    Location
    Wyoming
    Shooter
    Multi Format
    Posts
    585

    Olympus OM Prism Foam Problem

    I just discovered this. Does anyone know which models are affected? Is it only the OM-1's and 2's, or are the newer 1n and 2n models affected as well?

    Thanks,

    Bruce

  2. #2
    Andy K's Avatar
    Join Date
    Jul 2004
    Location
    Sunny Southend, England.
    Shooter
    Multi Format
    Posts
    9,422
    Images
    81
    Whats the problem?


    -----------My Flickr-----------
    Anáil nathrach, ortha bháis is beatha, do chéal déanaimh.

  3. #3

    Join Date
    May 2005
    Location
    Norway
    Shooter
    Multi Format
    Posts
    67
    Images
    12
    Not a direct answer to the question, but those interested can find some useful information here:http://olympus.dementia.org/Hardware...val/index.html

    Which reminds me that I have an OM-1 awaiting treatment...

    Knut

  4. #4

    Join Date
    Oct 2004
    Shooter
    Multi Format
    Posts
    726
    I have a house full of OMs and have never seen this problem. My 1 and 2s are all the n models, so maybe they aren't affected.

    David.

  5. #5
    BruceN's Avatar
    Join Date
    Aug 2004
    Location
    Wyoming
    Shooter
    Multi Format
    Posts
    585
    Quote Originally Posted by Woolliscroft
    I have a house full of OMs and have never seen this problem. My 1 and 2s are all the n models, so maybe they aren't affected.

    David.
    I think it's one of those things that is just a matter of time. They can last longer in some climates, etc., but if the foam is in there it WILL eventually deteriorate and take the silver off the prism. I have 4 OM's and none of them have had this happen, but I don't want to take the chance. I have a friend that has an OM-1 this has happened to - it doesn't affect the image on film, just drives you crazy when you look through the viewfinder.

  6. #6
    resummerfield's Avatar
    Join Date
    Jan 2005
    Location
    Alaska
    Shooter
    Large Format
    Posts
    1,268
    The Nikon F has the same problem with the Plain Prism. Some are worse than others, I guess depending on how they were stored. If you start to see the slightest visible effect in the pentaprism, I would replace the foam. Otherwise, wait for a "scheduled" trip to the repair shop.
    —Eric

  7. #7

    Join Date
    Sep 2002
    Location
    Boston, MA
    Shooter
    Multi Format
    Posts
    970
    Images
    3
    My Mamiya M645 prism had a similar problem. The foam's adhesive ate away at the mirror finish right in the middle of the viewing area. I removed the rest of the foam and attached a small mirror piece facing in to the prism. It works but you can see a slight band. The only other way is to have the prism re-mirrored. (I don't know if this is possible.)

    It should be a lot easier to have the mirror replaced on your OM.

    It is probably best to have the foam replaced before it turns to tar and effects the mirror surfaces.

  8. #8
    BruceN's Avatar
    Join Date
    Aug 2004
    Location
    Wyoming
    Shooter
    Multi Format
    Posts
    585
    I understand that the fix for the OM's is to simply clean out the old foam and reassemble the camera. Apparently they put the foam in to keep outside light from reaching the sensors near the viewfinder, but the consensus is that the top covers are light tight enough that the foam isn't necessary.


    I just ordered a set of the nice OM tools from Beljan Mfg. I think I'll do my beater OM-2n myself, and if that goes well I'll do the others myself, too.

  9. #9
    clogz's Avatar
    Join Date
    Dec 2002
    Location
    Rotterdam, The Netherlands
    Shooter
    Multi Format
    Posts
    2,835
    Images
    114
    Bruce,
    Have you got the website for Beljan?
    Thanks in advance
    Hans
    Digital is best taken with a grain of silver.

  10. #10
    BruceN's Avatar
    Join Date
    Aug 2004
    Location
    Wyoming
    Shooter
    Multi Format
    Posts
    585
    Hi Hans,

    He doesn't have a website, so far he does all of his selling on ebay. Here's a set:

    http://cgi.ebay.com/Olympus-OM-1-OM-...QQcmdZViewItem

    Not a bad price, for what you get. I'm told they are of the highest quality, but I'll reserve judgement until mine arrive.

    Bruce

    Quote Originally Posted by clogz
    Bruce,
    Have you got the website for Beljan?
    Thanks in advance
    Hans

Page 1 of 2 12 LastLast


 

APUG PARTNERS EQUALLY FUNDING OUR COMMUNITY:



Contact Us  |  Support Us!  |  Advertise  |  Site Terms  |  Archive  —   Search  |  Mobile Device Access  |  RSS  |  Facebook  |  Linkedin