Switch to English Language Passer en langue française Omschakelen naar Nederlandse Taal Wechseln Sie zu deutschen Sprache Passa alla lingua italiana
Members: 68,670   Posts: 1,481,772   Online: 1030
      
Results 1 to 5 of 5
  1. #1
    joeyk49's Avatar
    Join Date
    Jan 2004
    Location
    New Jersey, USA
    Shooter
    Multi Format
    Posts
    1,325
    Images
    26

    Quirky LCD frame advance/counter

    It hasn't been a good month for me and my Minoltas...first my X700 decided to play capacitor "Red Light/ Green Light" (You know, we all played it as kids: Turn your back and the kids run up to tag you. Look around and everyone stops...) and now my Minolta 450si frame counter takes a powder..

    Sometnig weird happened the other day:

    I was shooting away with my 450si, when I started hearing, what I thought was film being torn by the film advance motor and sprockets. After a couple more frames of this, I decided to bag the rest of the roll, rewind and start with a fresh roll. Popped in a new cannister and heard the same sound. Shot a few frames and bagged that roll too.

    The next time out with my camera, I loaded yet another roll of film and noticed that I was no longer hearing that tearing sound, but the frame counter in my LCD display wasn't showing anything. I wasted a few shots and heard the motor drive engage, but still no frame count! Every other function in the display works fine, just no frame count...

    Could the problem be bulk loaded film? I use Kalt cannisters, which don't come with DX strips on them, but I'm suspecting something mechanical. Its really the first time I've used this camera/cannister combo.

    Has anyone ever encountered something like this before? I haven't developed the shot film yet, so I don't know if the drive was advancing properly or not.

  2. #2
    joeyk49's Avatar
    Join Date
    Jan 2004
    Location
    New Jersey, USA
    Shooter
    Multi Format
    Posts
    1,325
    Images
    26
    I think I've got it figure...with a sigh of relief...

    I just popped out the latest roll of bulk load and closed the back. Powered the camera up and whaddayaknow....frame counter says, "0"...popped in a roll of factory tri x and the film counter decides its going to play !

    ... So who's the brain surgeon at Minolta that let the camera operate without DX film canisters, but not let the film counter function?!! Aargh!

    Now this really shouldn't be a big deal. I shoot till the camera automatically rewinds, anyway. But its kinda nice to know howw many shots you have left before you have to reload.

    I guess I'll be looking for DX stickers soon...

  3. #3
    Dave Parker's Avatar
    Join Date
    Aug 2004
    Shooter
    Multi Format
    Posts
    4,049
    Many of the Maxxums work this way, if the canister does not have the DX code, the counter won't work, in many instances the camera itself will not function, it is not only minolta, I have run into this on some of the Canons and Nikons as well.

    Dave

  4. #4
    joeyk49's Avatar
    Join Date
    Jan 2004
    Location
    New Jersey, USA
    Shooter
    Multi Format
    Posts
    1,325
    Images
    26
    ....makes me appreciate my X700 more and more...

    you can't just rate and set the film, either...You have to calculate the number of stops difference and set the exposure compensation accordingly...and with no DoF preview....aaah! Don't get me started!

    Time to troll for stickers...

  5. #5
    Dave Parker's Avatar
    Join Date
    Aug 2004
    Shooter
    Multi Format
    Posts
    4,049
    If I remember right, Porters Cameras carrys DX stickers and I know they carry bulk DX cassettes as well

    www.porters.com

    Dave



 

APUG PARTNERS EQUALLY FUNDING OUR COMMUNITY:



Contact Us  |  Support Us!  |  Advertise  |  Site Terms  |  Archive  —   Search  |  Mobile Device Access  |  RSS  |  Facebook  |  Linkedin