Switch to English Language Passer en langue française Omschakelen naar Nederlandse Taal Wechseln Sie zu deutschen Sprache Passa alla lingua italiana
Members: 71,847   Posts: 1,582,757   Online: 887
      
Results 1 to 6 of 6
  1. #1

    Join Date
    Aug 2008
    Location
    Southern California
    Shooter
    35mm
    Posts
    46

    Vivitar series 1 70-210 macro question

    I recently purchased an FD mount Vivitar Series 1 70-210 macro lens for $40. It seems to be in great shape. The problem is it seems to be missing the filter thread on the front.
    Does anyone know how these lenses were put together and where I can find this missing piece?
    I tried a 67mm female to female coupling ring but it was too small for the male threads on the lens, even though the lens itself says 67mm diameter on it.
    It could be 72mm, but I wanted to make sure there isn't a proprietary Vivitar part that fits here before going off and spending more money trying to find a 72mm female to female coupling ring.

    Also, did I get a good price on it or was I a chump?

    Thanks,
    DB

  2. #2

    Join Date
    Jul 2006
    Location
    Greenville, SC
    Shooter
    Medium Format
    Posts
    264
    Quote Originally Posted by dracblau View Post
    I recently purchased an FD mount Vivitar Series 1 70-210 macro lens for $40. It seems to be in great shape. The problem is it seems to be missing the filter thread on the front.
    Does anyone know how these lenses were put together and where I can find this missing piece?
    I tried a 67mm female to female coupling ring but it was too small for the male threads on the lens, even though the lens itself says 67mm diameter on it.
    It could be 72mm, but I wanted to make sure there isn't a proprietary Vivitar part that fits here before going off and spending more money trying to find a 72mm female to female coupling ring.

    Also, did I get a good price on it or was I a chump?

    Thanks,
    DB
    There was 5 version for this, you might want to check out http://www.robertstech.com/vivitar.htm may provide some information also

    I have one and it is 67mm.

  3. #3

    Join Date
    Aug 2008
    Location
    Southern California
    Shooter
    35mm
    Posts
    46
    By the looks of the images on the site you included, it looks like I have a variant 1 lens.

  4. #4

    Join Date
    Apr 2004
    Location
    Montgomery, Il/USA
    Shooter
    Multi Format
    Posts
    5,305
    I think you're missing the filter ring. But if it appears to be there.........
    Part of the adjustments to be made if a lens like this is serviced especially relubed are internal adjustment to the front and rear groups to achieve infinity focus. If the lens has been relubed and assembled incorrectly by using the wrong thread on the helical the situation you see could be the result.
    The first variant is the one that made the reputation of the lens.
    Heavily sedated for your protection.

  5. #5

    Join Date
    May 2009
    Location
    San Diego, CA
    Shooter
    Medium Format
    Posts
    268
    Quote Originally Posted by John Koehrer View Post
    The first variant is the one that made the reputation of the lens.
    Perhaps, but the 2nd variant (Tokina) is at least as good, and the 3rd variant (Komine) is noticeably the best. I've owned all 3 of these in various mounts over the years. Incidentally, I currently own an autofocus version - Nikon AF mount - made by Cosina that appears to be optically distinct from either variant 4 or variant 5 (it's formula is 14 elements in 10 groups) that was bought new about 7 years ago for $100, and it's quite decent, certainly better than variants 4 and 5 were reputed to be. It's good enough that I've never been tempted to drop big bucks on a Nikon 80-200 or 70-200 lens.
    Last edited by dougjgreen; 05-12-2009 at 08:36 PM. Click to view previous post history.

  6. #6

    Join Date
    Aug 2008
    Location
    Southern California
    Shooter
    35mm
    Posts
    46
    Thanks for the replies.

    I think I am indeed missing the filter ring. Looking around, it seems to be harder to find than I thought. Looking at photos of the intact lens on the web, there is indeed supposed to be a ring where mine does not have one.

    I guess I will just have to be more careful with the lens and not rely on a filter to protect it.
    Last edited by dracblau; 05-12-2009 at 11:57 PM. Click to view previous post history.



 

APUG PARTNERS EQUALLY FUNDING OUR COMMUNITY:



Contact Us  |  Support Us!  |  Advertise  |  Site Terms  |  Archive  —   Search  |  Mobile Device Access  |  RSS  |  Facebook  |  Linkedin