Switch to English Language Passer en langue française Omschakelen naar Nederlandse Taal Wechseln Sie zu deutschen Sprache Passa alla lingua italiana
Members: 70,951   Posts: 1,557,956   Online: 1011
      
Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14
  1. #11

    Join Date
    Jun 2007
    Location
    Iowa
    Shooter
    35mm
    Posts
    1,053
    It turned out that the meter connection tab / flange on the lens mount was bent. Bending that back fixed the goofy metering. The shutter button is still not right but I can live with that, as the winder will provide a new new shutter button.
    In life you only get one great dog, one great car, and one great woman. Pet the dog. Drive the car. Make love to the woman. Don't mix them up.

  2. #12

    Join Date
    May 2006
    Location
    PO Box 231 New Underwood, SD 57761-0231
    Shooter
    Medium Format
    Posts
    192
    HAve you tried adjusting the length of "push" using a tiny flatblade screwdriver in the center of the shutter button? Most Pentax ME series have a slotted screw inside and it will adjust the amount of push required. They do loosen up with age and an easy fix.
    Gun Control is like: Reducing drunk driving by making it harder for SOBER people to buy cars.

  3. #13
    Carl V's Avatar
    Join Date
    Feb 2010
    Location
    Cheshire, England
    Shooter
    35mm
    Posts
    73
    Quote Originally Posted by Ted White View Post
    I have an MX and its shutter release is smooth and easy. Unfortunately the metering system leaves something to be desired.
    I had an MX myself back in the 1980s, and for a while before I eventually parted with it, the LED's kept flickering up and down. At first, it only occurred when you altered the lens aperture, but eventually it was doing it constantly. Other than that, mechanically it was a great camera.

  4. #14
    Randy_Va's Avatar
    Join Date
    Oct 2009
    Location
    Fairfax, VA
    Shooter
    35mm
    Posts
    60
    I have the weird metring issue on my ME Super. It seems that the contacts between certain apertures on each of my lenses just don't work right. I just turn to a different aperture to meter then put in manual to get the exposure I want in the aperture I want.

Page 2 of 2 FirstFirst 12


 

APUG PARTNERS EQUALLY FUNDING OUR COMMUNITY:



Contact Us  |  Support Us!  |  Advertise  |  Site Terms  |  Archive  —   Search  |  Mobile Device Access  |  RSS  |  Facebook  |  Linkedin