Switch to English Language Passer en langue française Omschakelen naar Nederlandse Taal Wechseln Sie zu deutschen Sprache Passa alla lingua italiana
Members: 71,948   Posts: 1,585,926   Online: 1029
      
Results 1 to 2 of 2
  1. #1

    Join Date
    Feb 2010
    Shooter
    35mm
    Posts
    1

    Canon A-1 shutter problem.

    I recently purchased a Canon A-1 with a couple of lenses and on first inspection it seemed to be in pretty good condition. However, now when i fire the shutter stays open for an unusual amount of time, no matter what shutter speed I have it set on. At first I thought it might be the battaries but after switching them I still incounter the same problem. In some cases I have to press the battery test button just to close the shutter.

    If anyone could shed some light on my problem that'd be awesome. I just want to know if I'm making some stupid rookie mistake before I take it into a repair shop and they point out my stupidity for all to see.

    Cheers.

  2. #2
    benjiboy's Avatar
    Join Date
    Apr 2005
    Location
    U.K.
    Shooter
    Multi Format
    Posts
    7,227
    You will find the A1 manual here http://web.archive.org/web/200511270...com/choose.htm study it, it could be that you haven't got it set up correctly, have the lens set at A and are on the manual exposure mode , you don't say what mode the camera was on or what the shutter speed should have been , read the manual and if you have any further questions ask again, I've used an A1 for more than twenty years.
    Ben



 

APUG PARTNERS EQUALLY FUNDING OUR COMMUNITY:



Contact Us  |  Support Us!  |  Advertise  |  Site Terms  |  Archive  —   Search  |  Mobile Device Access  |  RSS  |  Facebook  |  Linkedin