Switch to English Language Passer en langue française Omschakelen naar Nederlandse Taal Wechseln Sie zu deutschen Sprache Passa alla lingua italiana
Members: 70,299   Posts: 1,535,792   Online: 682
      
Page 3 of 3 FirstFirst 123
Results 21 to 22 of 22

Thread: F3 Problem?

  1. #21
    CGW
    CGW is offline

    Join Date
    Apr 2010
    Shooter
    Medium Format
    Posts
    2,798
    Know the drill well. Also painfully aware how non-authorized techs do "wall jobs" just like their automotive bretheren. Saw the part, saw the part # and schematic and the bulletin--no dice. Money wasn't a huge consideration since $200 buys high-rollage beaters with issues. My F3's still working--no complaints for a camera pushing 30 I've used steadily for 8 years.
    Last edited by CGW; 08-15-2010 at 01:56 PM. Click to view previous post history.

  2. #22
    lxdude's Avatar
    Join Date
    Apr 2009
    Location
    Redlands, So. Calif.
    Shooter
    Multi Format
    Posts
    6,628
    Something else that can cause LCD "fade" is dirty mirrors. Mine was getting dim and I decided to investigate. Without the prism it looked fine, so I figured it was inside the prism. A film had built up on the little mirrors inside and especially on the long one behind the faceplate which reflects into the prism. A careful cleaning and all is well.
    I do use a digital device in my photographic pursuits when necessary.
    When someone rags on me for using film, I use a middle digit, upraised.

Page 3 of 3 FirstFirst 123


 

APUG PARTNERS EQUALLY FUNDING OUR COMMUNITY:



Contact Us  |  Support Us!  |  Advertise  |  Site Terms  |  Archive  —   Search  |  Mobile Device Access  |  RSS  |  Facebook  |  Linkedin