Switch to English Language Passer en langue française Omschakelen naar Nederlandse Taal Wechseln Sie zu deutschen Sprache Passa alla lingua italiana
Members: 70,212   Posts: 1,532,080   Online: 1233
      
Results 1 to 4 of 4
  1. #1

    Join Date
    Mar 2010
    Shooter
    35mm
    Posts
    1

    yashica electro problem

    Hi all! When i load film and go to take up film slack, the rewinder doesn't ratchet to a "click.' Ruined a roll of film.... wondering if it needs fixing??? Thanks

  2. #2
    mjs
    mjs is offline

    Join Date
    Mar 2005
    Location
    Elkhart, Indiana (USA)
    Shooter
    Multi Format
    Posts
    1,105
    Images
    2
    Never heard that one before, sorry.

    Mike
    Life should not be a journey to the grave with the intention of arriving safely in a pretty and well preserved body, but rather to skid in broadside in a cloud of smoke, thoroughly used up, totally worn out, and loudly proclaiming– “Wow! What a Ride!”

    — Hunter S. Thompson

  3. #3

    Join Date
    Apr 2004
    Location
    Montgomery, Il/USA
    Shooter
    Multi Format
    Posts
    5,026
    Just take it up 'til there's a slight resistance, never heard a click unless it was the film breaking.
    Heavily sedated for your protection.

  4. #4

    Join Date
    Mar 2010
    Location
    England
    Shooter
    35mm RF
    Posts
    77
    Shouldn't this question be moved to the Rangefinder Forum...?



 

APUG PARTNERS EQUALLY FUNDING OUR COMMUNITY:



Contact Us  |  Support Us!  |  Advertise  |  Site Terms  |  Archive  —   Search  |  Mobile Device Access  |  RSS  |  Facebook  |  Linkedin