Switch to English Language Passer en langue française Omschakelen naar Nederlandse Taal Wechseln Sie zu deutschen Sprache Passa alla lingua italiana
Members: 70,295   Posts: 1,535,612   Online: 1114
      
Results 1 to 6 of 6
  1. #1

    Join Date
    Jun 2010
    Location
    Floor-it-duh
    Shooter
    Multi Format
    Posts
    1,127
    Images
    104

    Canon EF gods helllpppppp

    I have a 28-90 and an 80-200 that throw the Canon screen of death on my Rebel DSLR and a Canon EOS 650. My Nifty Fifty and Tamron 18-270 are fine. I get it if I step down my F-stop especially. It seems to be random but most common at f8.

    Contacts are cleaned. halp!
    5x7 Eastman-Kodak kit / B+M 135mm Zeiss Tessar + Compur Deckel
    RB67 Pro S /50 4.5 / 90 3.8 / 180 4.5 / WLF / prism finder / polaback
    FED-2 / 50 2.8 Industar 26m / 85 f2 Jupiter-9
    Canon 300v / A2

  2. #2
    Whiteymorange's Avatar
    Join Date
    Jul 2004
    Location
    Boston area
    Shooter
    Multi Format
    Posts
    2,275
    Images
    26
    Perhaps the wrong forum for a question like this? I'm sure more digital types would have quicker and better answers

  3. #3
    hpulley's Avatar
    Join Date
    Oct 2010
    Location
    Guelph, Ontario, Canada
    Shooter
    Multi Format
    Posts
    2,214
    Images
    75
    Hey, I have a 650 and a 28-80 II with exactly this problem so it is the right place to ask

    The death is a problem with the aperture. Either the motor is dead or the lubrication on the blades is seized up or moisture has gotten in there.For such cheap lenses as the 28-90 (or my 28-80 II) it isn't likely worth repairing them but if the 80-200 is the "magic drainpipe" then it is likely worth having fixed.

    Temporarly stop-gap measure is to use the lenses wide open or often I find if you put them at f/22 and press the DOF preview a zillion time it will work out the problem if it is mostly a lubrication issue. If the aperture motor is dead of course it won't help.
    Harry Pulley - Visit the BLIND PRINT EXCHANGE FORUM

    Happiness is...

  4. #4

    Join Date
    Jun 2010
    Location
    Floor-it-duh
    Shooter
    Multi Format
    Posts
    1,127
    Images
    104
    I hear clicking on the 80-200, it's the 4.5 slowmatic version. I think both lenses are fucked.
    5x7 Eastman-Kodak kit / B+M 135mm Zeiss Tessar + Compur Deckel
    RB67 Pro S /50 4.5 / 90 3.8 / 180 4.5 / WLF / prism finder / polaback
    FED-2 / 50 2.8 Industar 26m / 85 f2 Jupiter-9
    Canon 300v / A2

  5. #5
    hpulley's Avatar
    Join Date
    Oct 2010
    Location
    Guelph, Ontario, Canada
    Shooter
    Multi Format
    Posts
    2,214
    Images
    75
    Aperture motors are probably dead, sorry about your luck, problem with the EF mount all electric everything. They aren't the most expensive lenses at least.
    Harry Pulley - Visit the BLIND PRINT EXCHANGE FORUM

    Happiness is...

  6. #6
    MattKing's Avatar
    Join Date
    Apr 2005
    Location
    Delta, British Columbia, Canada
    Shooter
    Multi Format
    Posts
    12,277
    Images
    60
    If you were up in my corner of the continent, $40.00 might get you a replacement lens and a camera too!:

    http://vancouver.en.craigslist.ca/bn...104490732.html
    Matt

    “Photography is a complex and fluid medium, and its many factors are not applied in simple sequence. Rather, the process may be likened to the art of the juggler in keeping many balls in the air at one time!”

    Ansel Adams, from the introduction to The Negative - The New Ansel Adams Photography Series / Book 2



 

APUG PARTNERS EQUALLY FUNDING OUR COMMUNITY:



Contact Us  |  Support Us!  |  Advertise  |  Site Terms  |  Archive  —   Search  |  Mobile Device Access  |  RSS  |  Facebook  |  Linkedin