Switch to English Language Passer en langue française Omschakelen naar Nederlandse Taal Wechseln Sie zu deutschen Sprache Passa alla lingua italiana
Members: 70,497   Posts: 1,543,051   Online: 1014
      
Results 1 to 3 of 3
  1. #1

    Join Date
    Mar 2011
    Shooter
    35mm
    Posts
    1

    Minolta XG-1 Film Advancment Issues

    I got an XG-1 as a gift from a friend, but when I loan the film, I can't get the film to advance...I think the mechanism is "stripped" or something.
    When I move the film advance lever it starts to roll the film, then is feels as though it "slips" and the tension is gone. Any ideas on a fix?
    Also, what is the action of the film advancement couple on the bottom?
    If needed I can post a video or something of the issue if you think it would help.

    Thanks!

  2. #2
    Christopher Walrath's Avatar
    Join Date
    Dec 2005
    Location
    Milton, DE, USA
    Shooter
    4x5 Format
    Posts
    6,980
    Blog Entries
    29
    Images
    19
    That sounds like a job for your friendly, neighborhood camera repairperson.
    Thank you.
    CWalrath
    APUG BLIND PRINT EXCHANGE
    DE Darkroom

    "Wubba, wubba, wubba. Bing, bang, bong. Yuck, yuck, yuck and a fiddle-dee-dee." - The Yeti

  3. #3
    Wade D's Avatar
    Join Date
    Feb 2006
    Location
    Jamul, CA
    Shooter
    Multi Format
    Posts
    884
    Images
    3
    Make sure the rewind button on the bottom of the camera isn't stuck. If it's pushed in the film won't advance.



 

APUG PARTNERS EQUALLY FUNDING OUR COMMUNITY:



Contact Us  |  Support Us!  |  Advertise  |  Site Terms  |  Archive  —   Search  |  Mobile Device Access  |  RSS  |  Facebook  |  Linkedin