Switch to English Language Passer en langue française Omschakelen naar Nederlandse Taal Wechseln Sie zu deutschen Sprache Passa alla lingua italiana
Members: 71,516   Posts: 1,572,140   Online: 1048
      
Results 1 to 2 of 2
  1. #1

    Join Date
    Sep 2011
    Shooter
    35mm
    Posts
    1

    Nikon FE meter turns off when on f4, but all other apertures work fine.

    I have a FE that when I use F4 the meter seems to shut off. At any other apeture, everything works fine. I am the original owner of this camera and it has never had a problem. I am wondering if any one know what the problem is.
    The aperture ring moves smoothly, the batteries new and correct, but this is the only anomaly.

    Does anyone know to what the aperture ring attaches so that the meter works. I am guessing it must be something wrong with this part. Something like a variable resistor, potentiometer, or ? How difficult would it be to fix oneself, or how much is likely to cost to repair?

    Any insight is appreciated.

  2. #2
    fstop's Avatar
    Join Date
    Apr 2011
    Shooter
    35mm
    Posts
    698
    Rotate the aperture ring back and forth several times, move the ASA ring back and forth a few times as well as the EV adjustment. Often the contacts just need movement to "wipe" them.

    Try that first.



 

APUG PARTNERS EQUALLY FUNDING OUR COMMUNITY:



Contact Us  |  Support Us!  |  Advertise  |  Site Terms  |  Archive  —   Search  |  Mobile Device Access  |  RSS  |  Facebook  |  Linkedin