Switch to English Language Passer en langue française Omschakelen naar Nederlandse Taal Wechseln Sie zu deutschen Sprache Passa alla lingua italiana
Members: 71,872   Posts: 1,583,518   Online: 1021
      
Page 3 of 3 FirstFirst 123
Results 21 to 22 of 22
  1. #21
    leicarfcam's Avatar
    Join Date
    Oct 2006
    Location
    Fort Worth, Texas
    Shooter
    35mm RF
    Posts
    181
    These cameras were made in the 70's, and 80's. They are in need of a CLA. This is the usual behavior when service is needed. The electrical contacts also get dirty and cause erratic readings etc..

    Find a repair shop and explain what the camera is doing.....
    Leicarfcam aka Colyn

  2. #22

    Join Date
    Apr 2004
    Location
    Montgomery, Il/USA
    Shooter
    Multi Format
    Posts
    5,309
    Quote Originally Posted by David Lyga View Post
    In the past year I have seen two Nikon FE bodies whose shutter fired at only one speed: instantaneous. The meter worked fine but the timing chip was done and dead. So it happens with revered Nikon also. Given a choice, I'll take an FM any day. - David Lyga
    I've got an FE that doesn't work in auto And the meter needle doesn't move.......But the shutter works properly in Manual. =)
    Heavily sedated for your protection.

Page 3 of 3 FirstFirst 123


 

APUG PARTNERS EQUALLY FUNDING OUR COMMUNITY:



Contact Us  |  Support Us!  |  Advertise  |  Site Terms  |  Archive  —   Search  |  Mobile Device Access  |  RSS  |  Facebook  |  Linkedin