Switch to English Language Passer en langue française Omschakelen naar Nederlandse Taal Wechseln Sie zu deutschen Sprache Passa alla lingua italiana
Members: 71,522   Posts: 1,572,250   Online: 785
      
Results 1 to 2 of 2
  1. #1
    JLMoore3rd's Avatar
    Join Date
    Mar 2007
    Location
    Catonsville, MD USA
    Shooter
    4x5 Format
    Posts
    246
    Images
    1

    Norman P400D problems

    I have an old P400D power pack which blows the main fuse whenever it is triggered... Anyone have experience with these, or this problem?

    This has been sitting around quite a while & a friend is looking for an affordable small studio system.

    I'm thinking I might take this to a repair tech, if the repair wouldn't be too spendy.
    John "Alpha Flying Monkey" Moore
    http://www.flyingmonkeystudio.com

  2. #2
    David A. Goldfarb's Avatar
    Join Date
    Sep 2002
    Location
    Honolulu, Hawai'i
    Shooter
    Large Format
    Posts
    17,435
    Images
    20
    I've owned a P800D and P2000D and haven't had that problem, but it's either a short, or you don't have the right fuse. You could check with Photo-Control (which owns Norman) or a place like Flash Clinic in New York to confirm the fuse type.
    flickr--http://www.flickr.com/photos/davidagoldfarb/
    Photography (not as up to date as the flickr site)--http://www.davidagoldfarb.com/photo
    Academic (Slavic and Comparative Literature)--http://www.davidagoldfarb.com



 

APUG PARTNERS EQUALLY FUNDING OUR COMMUNITY:



Contact Us  |  Support Us!  |  Advertise  |  Site Terms  |  Archive  —   Search  |  Mobile Device Access  |  RSS  |  Facebook  |  Linkedin